Search found 47 matches

by mcurry
Tue Nov 17, 2020 8:03 pm
Forum: Running
Topic: Issue with PM concentrations and temperature at 2m over land
Replies: 4
Views: 32

Re: Issue with PM concentrations and temperature at 2m over land

This topic was originally posting in the Running section of the MPAS Forum, so it has been moved here.
by mcurry
Mon Oct 19, 2020 5:25 pm
Forum: Running
Topic: arc_bisect error when running JW Baroclinic Wave Idealized Case
Replies: 12
Views: 628

Re: arc_bisect error when running JW Baroclinic Wave Idealized Case

Sorry about the slow reply on this. Have you tried installing a different recommended versions of PIO (as specified in section 3.2.3 of the MPAS Users Guide )? I've also attached a file iolib_installation.sh, which we use to install the MPAS libraries. You'll need to edit it for your use case and it...
by mcurry
Mon Oct 19, 2020 5:09 pm
Forum: Running
Topic: Creating special CVT partitioning file for static interpolation
Replies: 2
Views: 155

Re: Creating special CVT partitioning file for static interpolation

Sorry about the late reply on this. Generating CVT partitions requires some non-trivial work to produce so CVT partitions are only included with the large meshes and we do not have plans on releasing the code to do so. However, we are working on a method for interpolating static fields in parallel w...
by mcurry
Tue Sep 01, 2020 4:29 pm
Forum: Running
Topic: GWDO error when running a limited-area simulation
Replies: 10
Views: 600

Re: GWDO error when running a limited-area simulation

I have updated the title of this post to better represent the nature of the error that occurred so that it may be easier to find by other users with the same problem.
by mcurry
Tue Sep 01, 2020 4:27 pm
Forum: Running
Topic: arc_bisect error when running JW Baroclinic Wave Idealized Case
Replies: 12
Views: 628

Re: arc_bisect error when running JW Baroclinic Wave Idealized Case

I have updated the title of this post to better represent the occurred error. The hope of this change is to better help users locate already answered errors they may be having.
by mcurry
Mon Aug 31, 2020 10:18 pm
Forum: Running
Topic: Define a regional domain
Replies: 6
Views: 372

Re: Define a regional domain

As well I've updated the tutorial branch of the MPAS-Limited-Area tool to be up-to-date with master, so it now can subset Time variant fields.
by mcurry
Mon Aug 31, 2020 6:16 pm
Forum: Running
Topic: Problems with running variable mesh in a regional domain
Replies: 4
Views: 336

Re: Problems with running variable mesh in a regional domain

Thanks for the great question! Yes I've think are missing the static interpolation step. It appears that you are trying to interpolate initial conditions, but appears you are trying to run the static interpolation, which, at present, can only be ran with a single processor. For reference, here is an...
by mcurry
Mon Aug 24, 2020 3:33 pm
Forum: Running
Topic: arc_bisect error when running JW Baroclinic Wave Idealized Case
Replies: 12
Views: 628

Re: Trouble running MPAS

My apologize, I meant log.init_atmosphere.0000.out, and not .txt. Thanks for sending your log files and thanks for your patience while working through this. I think the issue might be with your installation libraries, which I believe I missed before. Taking a look at the arc_bisect routine, which is...
by mcurry
Fri Aug 21, 2020 9:51 pm
Forum: Running
Topic: arc_bisect error when running JW Baroclinic Wave Idealized Case
Replies: 12
Views: 628

Re: Trouble running MPAS

Your setup and installation looks good and most likely isn't the problem. And you're right, I meant to say x1.40962.grid.nc. That is the file that the init_atmosphere will use for the setup of the JW baroclinic wave test. Will you be able to upload the entirety of the log that was produced when runn...
by mcurry
Thu Aug 20, 2020 2:58 pm
Forum: Running
Topic: arc_bisect error when running JW Baroclinic Wave Idealized Case
Replies: 12
Views: 628

Re: Trouble running MPAS

That's strange! The JW baroclinic wave test normally runs pretty well out of the box. Just to insure I know your exact setup, are you using the meshes that are found within the jw_baroclinic_wave.tar.gz and you have touched any of the namelist or streams? i.e. x1.40962.init.nc? I have also moved thi...
by mcurry
Wed Aug 12, 2020 6:49 pm
Forum: Post-processing
Topic: Plotting the output of a regional simulation
Replies: 4
Views: 368

Re: Plotting the output of a regional simulation

I recommend using the NCL script (regional_cells.ncl) referenced in step 4.5 Visualizing regional output as a good first place to view your regional fields (as well as ncview). You'll need to follow the example in 4.5 to changing the script to plot the field that you want and selecting the correct a...
by mcurry
Wed Aug 12, 2020 3:57 pm
Forum: Running
Topic: GWDO error when running a limited-area simulation
Replies: 10
Views: 600

Re: Fail to run limited-area simulation

Glad to see that you are no longer getting the GWDO error you were getting, ntmanhvn181. I have moved your last post in this thread into a new topic in the post-processing forum as its more related to post processing rather than running. You can see the new topic here: https://forum.mmm.ucar.edu/php...
by mcurry
Tue Aug 11, 2020 4:08 pm
Forum: Running
Topic: GWDO error when running a limited-area simulation
Replies: 10
Views: 600

Re: Fail to run limited-area simulation

Your setup process looks correct and the `ter` field of vietnam.static.nc is present and looks correct so I can see that it has been interpolated with static fields (as you noted you did). Did you still get the GWDO error that you received in your first post when running on this vietnam.static.nc me...
by mcurry
Mon Aug 10, 2020 3:21 pm
Forum: Running
Topic: GWDO error when running a limited-area simulation
Replies: 10
Views: 600

Re: Fail to run limited-area simulation

Looks like that is the correct setup for the interpolation of static and GWDO fields.

Does the 'ter' (terrain) field of vietnam.grid.nc contain all zeros when it should not? (i.e. your simulation is over land). Are you trying to run a simulation completely over water?
by mcurry
Fri Aug 07, 2020 5:21 pm
Forum: Running
Topic: GWDO error when running a limited-area simulation
Replies: 10
Views: 600

Re: Fail to run limited-area simulation

Thanks for the clarification on your process. If you started your process from x5.6488066.grid.nc and not the provided x1.163842.static.nc then step 4 of the tutorial will not work correctly as it is written to start with a mesh that contains static terrestrial fields (These fields include: terrain ...
by mcurry
Fri Aug 07, 2020 4:38 pm
Forum: Running
Topic: GWDO error when running a limited-area simulation
Replies: 10
Views: 600

Re: Fail to run limited-area simulation

This problems usually occurs when your initialization file does not contain any GWDO fields. Are you using the mesh provided at the top of the tutorial page (found in the mpas_tutorial.tar.gz file)? The x1.163842.static.nc file provided in that tar file contains all the necessary static fields (incl...
by mcurry
Thu Aug 06, 2020 3:50 pm
Forum: Running
Topic: Define a regional domain
Replies: 6
Views: 372

Re: Define a regional domain

Great! I'm glad it worked for you!
by mcurry
Wed Aug 05, 2020 5:19 pm
Forum: Running
Topic: Define a regional domain
Replies: 6
Views: 372

Re: Define a regional domain

It looks like create_region is failing while subsetting the qv field from x1.163842.static.nc. However, I'm not seeing the qv field from the x1.163842.static.nc static file that was provided with the tutorial. Just to confirm, are you using the x1.163842.static.nc file from the tar file located just...
by mcurry
Wed Jun 24, 2020 12:18 am
Forum: Compilation / installation
Topic: Creating .nc file using Greate_Region.
Replies: 4
Views: 467

Re: Creating .nc file using Greate_Region.

This post appears it was duplicated by accident. Because each post slightly differs, I have merged them together. Before I answer your two questions, it appears that you are using the custom method for creating your region instead of the tropics method. Creating a tropics method should only contain ...
by mcurry
Tue Jun 23, 2020 7:51 pm
Forum: Code development
Topic: Inserting write-statements into PIO
Replies: 16
Views: 775

Re: Inserting write-statements into PIO

Is execution getting to the output statements in PIO? Does a write statement in a higher level MPAS function such as a the run function in mpas_atm_core.F or mpas_init_atm_core.F produce output? Is it possible to open a file a write to it? I'm using the OpenACC version of MPAS-A which may be a snaps...
by mcurry
Mon Jun 08, 2020 5:42 pm
Forum: Running
Topic: Static Initialization Failure - 15km uniform mesh
Replies: 10
Views: 798

Re: Static Initialization Failure - 15km uniform mesh

The current static implementation of the static initialization is quite memory intensive. This often leads to this type of error because there is often a limit upon the amount of memory that can be allocated by one program (i.e. the stack size). Depending on your chosen shell you can set the stack s...
by mcurry
Wed May 13, 2020 3:57 pm
Forum: Running
Topic: mpas_timekeeping.F: Fortran runtime error - Bad integer for item 1 in lnput
Replies: 6
Views: 386

Re: mpas_timekeeping.F: Fortran runtime error - Bad integer for item 1 in lnput

Yes! Enabling SST updates must be done in two places. This often is missed as it was by me. Glad you got it working!
by mcurry
Tue May 12, 2020 8:09 pm
Forum: Post-processing
Topic: make convert_mpas error with gfortran
Replies: 3
Views: 320

Re: make convert_mpas error with gfortran

gfortran 4.8.5 is quite an old version of GCC. The version you are using is also the default Red Hat version hence the: (Red Hat 4.8.5-36) from the --version command. I recommend using a more recent version of GCC, at least any version past 7. For reference the default on Cheyenne is GCC 8.3.0, whic...
by mcurry
Tue May 12, 2020 4:39 pm
Forum: Running
Topic: mpas_timekeeping.F: Fortran runtime error - Bad integer for item 1 in lnput
Replies: 6
Views: 386

Re: mpas_timekeeping.F: Fortran runtime error - Bad integer for item 1 in lnput

Thanks for attaching those files. I'm not sure if this is the cause of the problem, but I am noticing that your horizontal length scale (config_len_disp in the nhyd_model section of the namelist.atmosphere) appears to be too large for the 60-10km mesh as well, your time step (config_dt) might also b...
by mcurry
Mon May 11, 2020 11:20 pm
Forum: Running
Topic: mpas_timekeeping.F: Fortran runtime error - Bad integer for item 1 in lnput
Replies: 6
Views: 386

Re: mpas_timekeeping.F: Fortran runtime error - Bad integer for item 1 in lnput

It seems like it might be an syntax error in specifying the time in the namelist.atmosphere. Posting the it (namelist.atmosphere) as well as the log.atmosphere.0000.out would be helpful. To attach a file on this forum click 'Post Reply' or 'Full Editor & Preview' below this post. Then, below the tex...

Go to advanced search