Search found 420 matches

by mgduda
Tue Feb 23, 2021 5:46 pm
Forum: geogrid
Topic: geogrid bad interpolation along coastline
Replies: 2
Views: 13

Re: geogrid bad interpolation along coastline

That the ALBEDO12M field looks coarser near land-sea boundaries sounds more like evidence that the geogrid program is not using water values. The 'index' file for the 'albedo_modis' dataset contains the following: type=continuous projection=regular_ll dx=0.05 dy=-0.05 known_x=1.0 known_y=1.0 known_l...
by mgduda
Tue Feb 23, 2021 4:56 pm
Forum: WRF Compiling/Installation
Topic: WRF configure on HPC, Not found netcdf.inc
Replies: 2
Views: 7

Re: WRF configure on HPC, Not found netcdf.inc

I've moved this thread from the WPS compilation section to the WRF compilation section.
by mgduda
Tue Feb 23, 2021 4:48 pm
Forum: Special Running Options
Topic: Long-time WRF simulation
Replies: 3
Views: 20

Re: Long-time WRF simulation

I've moved this thread to the "Running WRF" > "Special Running Options" section of the forum, since the question concerns WRF rather than MPAS.
by mgduda
Tue Feb 23, 2021 3:17 am
Forum: geogrid
Topic: Taking too long to run ./geogrid.exe GREENFRAC
Replies: 7
Views: 91

Re: Taking too long to run ./geogrid.exe GREENFRAC

I also tried adding in four_pt to the GEOGRID.TBL file and got the following error: Parsed 29 entries in GEOGRID.TBL Processing domain 1 of 1 ERROR: Could not open /WPS/WPS_GEOG/greenfrac_fpar_modis+four_pt/index application called MPI_Abort(MPI_COMM_WORLD, 33242704) - process 0 In: PMI_Abort(33242...
by mgduda
Tue Feb 23, 2021 12:27 am
Forum: Running
Topic: Model Integration hangs using 1024cores
Replies: 1
Views: 29

Re: Model Integration hangs using 1024cores

The "bootstrapping" part of the model start-up involves reading in the fields from the input NetCDF file that describe the horizontal mesh, reading the mesh partition (graph.info.part.X) information, and working out the cells/edges/vertices that belong in the "halo" regions on each MPI task. My init...
by mgduda
Mon Feb 22, 2021 11:34 pm
Forum: Running
Topic: Minimum computer requirements for running MPAS
Replies: 3
Views: 43

Re: Minimum computer requirements for running MPAS

That is to say, if I were to run MPAS on a personal desktop, the main limit will be the amount of RAM and number of cells? With 12 GB RAM (leaving 4 from 16 GB for the main OS usage), that is roughly 68,571 cells with the default config and physics. That's correct. Again, the 0.175 MB/cell figure i...
by mgduda
Mon Feb 22, 2021 9:42 pm
Forum: Post-processing
Topic: Error during make of convert_mpas
Replies: 2
Views: 11

Re: Error during make of convert_mpas

Can you attach your compilation log at a text file (or if it's short enough, just include it in a follow-up post)? When creating the log, you'll want to ensure that stderr and stdout messages are both saved to the log using >& redirection.
by mgduda
Thu Feb 18, 2021 11:08 pm
Forum: Running
Topic: Minimum computer requirements for running MPAS
Replies: 3
Views: 43

Re: Minimum computer requirements for running MPAS

Regarding memory requirements, we've found that a reasonable way to estimate the amount of memory needed to run a particular simulation is to multiply the number of horizontal cells in the mesh by 0.175 MB/cell; this estimate is based on a single-precision model run with around 55 vertical levels. S...
by mgduda
Sat Feb 13, 2021 12:14 am
Forum: Running
Topic: config_jedi_da = F
Replies: 10
Views: 82

Re: config_jedi_da = F

When compiled with DEBUG=true, the model will probably run about an order of magnitude slower than usual. I was actually hoping that the model would have stopped with a filename and line number where the invalid read was occurring.
by mgduda
Fri Feb 12, 2021 10:14 pm
Forum: Running
Topic: config_jedi_da = F
Replies: 10
Views: 82

Re: config_jedi_da = F

zmenzo wrote:
Fri Feb 12, 2021 9:32 pm
Would I include "debug" in the following way:

make clean CORE=atmosphere
make ifort CORE=atmosphere PRECISION=double USE_PIO2=true DEBUG=true
make clean CORE=init_atmosphere
make ifort CORE=init_atmosphere PRECISION=double USE_PIO2=true DEBUG=true
That's correct.
by mgduda
Fri Feb 12, 2021 9:30 pm
Forum: Running
Topic: config_jedi_da = F
Replies: 10
Views: 82

Re: config_jedi_da = F

The error message forrtl: severe (59): list-directed I/O syntax error, unit -5, file Internal List-Directed Read Image PC Routine Line Source atmosphere_model 000000000103836B Unknown Unknown Unknown atmosphere_model 00000000010619A1 Unknown Unknown Unknown atmosphere_model 00000000010606C5 Unknown ...
by mgduda
Fri Feb 12, 2021 9:24 pm
Forum: Running
Topic: Problem with running MPAS with ERA Interim model level files
Replies: 6
Views: 1682

Re: Problem with running MPAS with ERA Interim model level files

It seems as though there may be some mismatch in the vertical levels in your ERA-Interim intermediate files. Your 'ecmwf_coeffs' file has 138 levels, while your log.init_atmosphere.0000.out_ec_init suggests that your PRESSURE and other 3-d fields have only a subset of these levels.
by mgduda
Fri Feb 12, 2021 9:02 pm
Forum: Running
Topic: config_jedi_da = F
Replies: 10
Views: 82

Re: config_jedi_da = F

Did your job produce any log.atmosphere.XXXX.err files?
by mgduda
Fri Feb 12, 2021 8:49 pm
Forum: Compilation / installation
Topic: MPAS-A installation failed due to pio1.f90 and pio2.f90
Replies: 5
Views: 140

Re: MPAS-A installation failed due to pio1.f90 and pio2.f90

There is also a known issue with the PIO 2.5.2 library in MPAS; see MPAS-Model Issue #695 and the fix in PR #707 . There are a couple of ways that you could work around this in MPAS v7.0: You could install PIO 2.4.4 rather than PIO 2.5.2 You could locally merge the changes from PR #707 onto the MPAS...
by mgduda
Fri Feb 12, 2021 8:34 pm
Forum: Compilation / installation
Topic: MPAS-A installation failed due to pio1.f90 and pio2.f90
Replies: 5
Views: 140

Re: MPAS-A installation failed due to pio1.f90 and pio2.f90

The first error in your MPAS compilation log is mpas_derived_types.F:30:7: use pio 1 Fatal Error: Can't open module file ‘pio.mod’ for reading at (1): No such file or directory From your compilation log, it looks like you may have installed PIO in /home/metdu/allmodel/pio . Can you list the /home/me...
by mgduda
Fri Feb 12, 2021 8:29 pm
Forum: Compilation / installation
Topic: MPAS 7.0 A failed on pio1.f90.
Replies: 3
Views: 47

Re: MPAS 7.0 A failed on pio1.f90.

I was expecting it to use the zlib compiled in the installation guide. How do I make sure MPAS use the zlib manually compiled instead of the one installed through apt for system wide. Should I make a new topic for it? You may be able to direct the linker to use the zlib library from your own direct...
by mgduda
Fri Feb 12, 2021 8:26 pm
Forum: Compilation / installation
Topic: MPAS 7.0 A failed on pio1.f90.
Replies: 3
Views: 47

Re: MPAS 7.0 A failed on pio1.f90.

Just for the benefit of anyone else who might happen upon this thread, there appears to be another thread discussing the same issue: viewtopic.php?f=10&t=9902 .
by mgduda
Tue Feb 09, 2021 4:44 pm
Forum: Running
Topic: different results from different number of processors (resolved)
Replies: 3
Views: 38

Re: different results from different number of processors (resolved)

Thanks for following up, and I'm glad to hear you've tracked down the issue!
by mgduda
Tue Feb 09, 2021 4:55 am
Forum: Running
Topic: different results from different number of processors (resolved)
Replies: 3
Views: 38

Re: different results from different number of processors

We have seen similar issues that appear to be the result of compiler optimizations of various sorts. Have you tried turning off optimizations in the make target for your compiler in the top-level Makefile to see whether that enables you to get bitwise identical results for different MPI task counts?...
by mgduda
Thu Jan 28, 2021 10:38 pm
Forum: Running
Topic: Invalid DateTime string in x1.655362.static.nc
Replies: 8
Views: 185

Re: Invalid DateTime string in x1.655362.static.nc

@Geess_321 - Thanks very much for pointing out the io_type="netcdf4" solution! I have a suspicion that there may be an issue in the parallel-NetCDF (pnetcdf) library; we've run into problems in writing character-type variables via pnetcdf in the past (though I'm struggling to recall the specific cir...
by mgduda
Thu Jan 28, 2021 9:10 pm
Forum: Compilation / installation
Topic: (Resolved) Invalid character in name when compiling init_atmosphere core
Replies: 12
Views: 198

Re: MPAS init_atmosphere compile error

That's great to hear, and thanks very much for following-up!
by mgduda
Thu Jan 28, 2021 9:08 pm
Forum: metgrid
Topic: metgrid error (Didn't recognize format version of data in FILE)
Replies: 19
Views: 1135

Re: metgrid error (Didn't recognize format version of data in FILE)

Assuming the Intel Fortran compiler, I think the attached makefile should work. Note that the environment variable NETCDF will probably need to be set to the path where the NetCDF library has been installed.
by mgduda
Thu Jan 28, 2021 8:39 pm
Forum: Compilation / installation
Topic: (Resolved) Invalid character in name when compiling init_atmosphere core
Replies: 12
Views: 198

Re: MPAS init_atmosphere compile error

It appears as though the symbolic links have been converted into regular files. I'm not sure whether this might be due to an issue on GitHub's side when creating the tar file or to an issue in unpacking the tar file. An alternative way to obtain the 'hotfix-v7.1' code would be to use the 'git' comma...
by mgduda
Thu Jan 28, 2021 8:33 pm
Forum: GPU / OpenACC
Topic: OpenACC directives at mpas_dmpar.F
Replies: 1
Views: 80

Re: OpenACC directives at mpas_dmpar.F

Thanks so much for pointing out these issues! Bringing the GPU-enabled MPAS-A code up-to-date with the v7.0 release is a work in progress, and we'll work to address these issues as we go.
by mgduda
Thu Jan 28, 2021 8:25 pm
Forum: Science
Topic: Bias in 2m and surface temperature
Replies: 2
Views: 165

Re: Bias in 2m and surface temperature

Apologies for the silence on this issue. For my part, I don't have any good suggestions on where the issue might lie, so I've refrained from posting in hopes that others might be able to offer some insight or suggestions.

Is this still an issue under investigation?

Go to advanced search