Search found 466 matches

by mgduda
Wed Jun 23, 2021 10:23 pm
Forum: Running
Topic: Error while running 60 km mesh
Replies: 3
Views: 36

Re: Error while running 60 km mesh

The plot of your variable resolution mesh looks fine to me. It may be worth pointing out that you may not need to set the rotation of the mesh as 180 degrees in your namelist.input file: config_birdseye_rotation_counter_clockwise_degrees = 180 Rotating an elliptical region by 180 degrees about its c...
by mgduda
Tue Jun 22, 2021 2:36 am
Forum: Running
Topic: Creating LBCS using MPAS global simulation output
Replies: 2
Views: 38

Re: Creating LBCS using MPAS global simulation output

We do have some experimental code for interpolating LBCs for a regional MPAS simulation from global MPAS output. However, we don't have any tools for interpolating ICs for regional MPAS simulations from global MPAS output, as this requires a bit more work to handle masked land-surface fields. I'll t...
by mgduda
Thu May 27, 2021 2:54 am
Forum: geogrid
Topic: Bathymetry (lake data) origin (RESOLVED)
Replies: 2
Views: 236

Re: Bathymetry (lake data) origin

Although I don't actually know where the lake depth dataset originates, this comment at the top of WRF's module_sf_lake.F may be helpful: ! The lake scheme was retrieved from the Community Land Model version 4.5 ! (Oleson et al. 2013) with some modifications by Gu et al. (2013). It is a ! one-dimens...
by mgduda
Wed May 26, 2021 11:58 pm
Forum: Running
Topic: Best Practices
Replies: 3
Views: 255

Re: Best Practices

If you're running on Cheyenne in either the "economy", "regular", or "premium" queues, you're automatically given exclusive use of the nodes allocated to your job, so using ncpus=36 and mpiprocs=36 would make maximal use of the nodes. It's been a while since I've tried, but using SMT on the Broadwel...
by mgduda
Wed May 26, 2021 10:57 pm
Forum: Post-processing
Topic: Convert_MPAS
Replies: 1
Views: 184

Re: Convert_MPAS

The default flags should work for the GNU Fortran compiler, but you may be able to get slightly better runtime performance with the following:

Code: Select all

-Ofast -ffree-form -Wall -DHAVE_NF90_INQ_VARIDS
by mgduda
Mon May 24, 2021 10:35 pm
Forum: Running
Topic: Best Practices
Replies: 3
Views: 255

Re: Best Practices

Apologies for the long delay in posting a reply. I had a few thoughts that might help: Compiling the model to use default single-precision real values might increase the computational throughput over default double-precision reals by around 30-35% on Cheyenne; you can select a single-precision build...
by mgduda
Mon May 24, 2021 10:06 pm
Forum: Compilation / installation
Topic: How to successfully install PIO 1.9.23?
Replies: 8
Views: 445

Re: How to successfully install PIO 1.9.23?

(base) [hongyongyu@login01 pio]$ make Done updating dependencies make[1]: Entering directory `/ddn_lustre/hongyongyu/MPAS/LIBplus/ParallelIO-pio1_7_1/pio' make[1]: `libpio.a' is up to date. make[1]: Leaving directory `/ddn_lustre/hongyongyu/MPAS/LIBplus/ParallelIO-pio1_7_1/pio' (base) [hongyongyu@l...
by mgduda
Mon May 24, 2021 9:59 pm
Forum: Running
Topic: ERROR: MPAS IO Error: Bad return value from PIO
Replies: 10
Views: 294

Re: ERROR: MPAS IO Error: Bad return value from PIO

@ntmanhvn181 Thanks for following up. It's good to hear that adding clobber_mode="overwrite" to the "restart" stream worked!
by mgduda
Mon May 24, 2021 9:36 pm
Forum: Post-processing
Topic: The MPAS output file is not recognized
Replies: 3
Views: 151

Re: The MPAS output file is not recognized

I can add that the 'ncmpidump' command that is provided as part of the Parallel-NetCDF library installation should work with your CDF-5 output files. To confirm that your static files are in another format (perhaps CDF-2, which is supported by default in the NetCDF library), you could run, e.g., ncm...
by mgduda
Mon May 24, 2021 9:27 pm
Forum: Post-processing
Topic: The MPAS output file is not recognized
Replies: 3
Views: 151

Re: The MPAS output file is not recognized

It may be that your NetCDF library wasn't compiled with support for reading and writing the CDF-5 format, which is provided by the Parallel-NetCDF library. I think the 60-3 km mesh has few enough grid cells that -- assuming around 55 vertical levels -- the CDF-5 large-variable format isn't necessary...
by mgduda
Wed May 12, 2021 9:46 pm
Forum: Running
Topic: ERROR: MPAS IO Error: Bad return value from PIO
Replies: 10
Views: 294

Re: ERROR: MPAS IO Error: Bad return value from PIO

@ntmanhvn181 Could you try your simulation again, but first ensure that any existing output files have been removed? It's possible that there is an issue with overwriting existing output (even though you have specified clobber_mode="overwrite" in your stream definitions). The issue seems to be with ...
by mgduda
Wed May 12, 2021 9:39 pm
Forum: Running
Topic: ERROR: MPAS IO Error: Bad return value from PIO
Replies: 10
Views: 294

Re: ERROR: MPAS IO Error: Bad return value from PIO

@jhegarty I think the issue in your case may be the definition of the "diagnostics" stream: <stream name="diagnostics" type="output" filename_template="diagnostics.$Y-$M-$D_$h:$m:$s.nc" output_interval="1:00:00"> <stream name="diagnostics"/> </stream> The definition is recursive, in that the content...
by mgduda
Fri May 07, 2021 3:46 pm
Forum: geogrid
Topic: ERROR: Could not open /work/hu/alkhasoneh/geog_data_high_res/topo_gmted2010_30s/index
Replies: 1
Views: 109

Re: ERROR: Could not open /work/hu/alkhasoneh/geog_data_high_res/topo_gmted2010_30s/index

The error message from geogrid ("ERROR: could not open ... /index") suggests that the geographical data may not have been unpacked in the directory specified in your namelist.wps file with the 'geog_data_path' variable. Could you try listing two directories and let us know the result? ls -l /work/hu...
by mgduda
Wed May 05, 2021 5:38 pm
Forum: Post-processing
Topic: Missing output variables
Replies: 4
Views: 206

Re: Missing output variables

The "Allocated by: jedi_da" note in the User's Guide for the spechum field does indicate that this field will only be allocated and accessible in MPAS-Atmosphere if the "jedi_da" package is active, which only happens when the namelist option config_jedi_da is true. Interestingly, a grep through the ...
by mgduda
Wed May 05, 2021 1:14 am
Forum: Running
Topic: Reducing Variable Output
Replies: 1
Views: 129

Re: Reducing Variable Output

You can modify the interval at which any output stream is written by changing the value of the "output_interval" attribute of that stream in the streams.atmosphere file. Note that an interval of "none" will turn off the output for a stream entirely. You can also modify the set of fields that are wri...
by mgduda
Mon May 03, 2021 10:50 pm
Forum: Running
Topic: ERROR: MPAS IO Error: Bad return value from PIO
Replies: 10
Views: 294

Re: ERROR: MPAS IO Error: Bad return value from PIO

@Jen If you're seeing the same PIO error on Cheyenne, I'd be glad to see whether I can reproduce it and track down the cause. Could you let me know which directory you're running in?
by mgduda
Fri Apr 23, 2021 8:42 pm
Forum: Running
Topic: How to create the 2 nested mesh with the different resolution
Replies: 3
Views: 204

Re: How to create the 2 nested mesh with the different resolution

Just to make sure I understand the question, are you asking how you can plot just the geographical region that is covered by the (approximately) 3-km part of the mesh? Unlike as in nested-grid models, there is a single, continuous grid with smoothly varying grid spacing in MPAS; for example: 60-3_me...
by mgduda
Tue Apr 20, 2021 9:31 pm
Forum: WPS Compiling/Installation
Topic: module_stringutil.F - invalid character
Replies: 2
Views: 114

Re: module_stringutil.F - invalid character

Before going through the effort of updating compilers, it might be worth first verifying that the "module_stringutils.F" file in the WPS/geogrid/src directory is a valid symbolic link to ../../ungrib/src/module_stringutils.F . For example, in my copy of the WPS code, I see the following in the geogr...
by mgduda
Tue Apr 20, 2021 3:53 pm
Forum: Running
Topic: ERROR: MPAS IO Error: Bad return value from PIO
Replies: 10
Views: 294

Re: ERROR: MPAS IO Error: Bad return value from PIO

Could you attach your log.atmosphere.0000.out file? The "ERROR: MPAS IO Error: Bad return value from PIO" error message is usually associated with stream output rather than stream input, and it would be helpful to get an idea of which output stream might be the problem. How many horizontal grid cell...
by mgduda
Fri Apr 09, 2021 3:43 am
Forum: Running
Topic: MPAS simulation end before reaching the final time
Replies: 2
Views: 162

Re: MPAS simulation end before reaching the final time

What is the resolution of your limited-area mesh? I think either your timestep ("config_dt") or your horizontal mixing length scale ("config_len_disp") may be set incorrectly: config_dt is set to 180.0 (which would be appropriate for a ~30 km mesh) while config_len_disp is set to 3000.0 (which would...
by mgduda
Wed Apr 07, 2021 5:05 pm
Forum: Post-processing
Topic: Error during make of convert_mpas
Replies: 19
Views: 603

Re: Error during make of convert_mpas

Thanks for the new log file. It looks like the errors are all link-time errors related to PnetCDF and MPI: /datadrive/models/mpas_install/libraries/lib/libnetcdf.a(libdispatch_la-derror.o): In function `nc_strerror': derror.c:(.text+0x46b): undefined reference to `ncmpi_strerror' derror.c:(.text+0x4...
by mgduda
Mon Apr 05, 2021 9:52 pm
Forum: Running
Topic: except EOFError when running tutorial examples
Replies: 1
Views: 137

Re: except EOFError when running tutorial examples

This looks like it may be a problem with your MPI implementation (specifically, in the 'mpiexec' command, which may be a script). If you have any other MPI "hello, world" programs, could you try running one of them in parallel with 'mpiexec'? It may even be a useful test to try running 'mpiexec --ve...
by mgduda
Mon Apr 05, 2021 9:47 pm
Forum: Post-processing
Topic: Error during make of convert_mpas
Replies: 19
Views: 603

Re: Error during make of convert_mpas

Can you provide the output from the following commands: nc-config --fflags nc-config --flibs Could you also attach a new log file created by running the following (with nc-config in your PATH and with an unmodified Makefile): make >& make.log Your original log file (log.txt) only shows errors due to...
by mgduda
Fri Mar 26, 2021 6:02 pm
Forum: Running
Topic: x4.2562 and x4.10242 VR mesh generation
Replies: 3
Views: 222

Re: x4.2562 and x4.10242 VR mesh generation

I've just uploaded these two meshes to our web server. I've placed them in a new "experimental" directory, since they haven't been thoroughly tested yet. Here are the links: x4.2562.tar.gz x4.10242.tar.gz Based on the distribution of cell-to-cell distances in the histograms, below, I think setting c...
by mgduda
Fri Mar 26, 2021 4:08 pm
Forum: Running
Topic: Error while running init_atmosphere_atmosphere for lbc conditions in regional domain
Replies: 7
Views: 290

Re: Error while running init_atmosphere_atmosphere for lbc conditions in regional domain

Thanks for following up! It's good to hear that adding "./" worked.

Go to advanced search