(SOLVED) Ungrib segmentation fault

Topics related to running the ungrib.exe program
Post Reply
elliottardif
Posts: 12
Joined: Tue Jan 07, 2020 4:52 pm

(SOLVED) Ungrib segmentation fault

Post by elliottardif » Tue Jan 07, 2020 5:04 pm

Hi everyone, I am attempting to run WPS within WRFv4.1.2, and I am running into a problem with ungrib. It gives a segmentation fault immediately after running the executable (see text below). I have no further information on anything ungrib is running prior to the segmentation fault. Unlimit and the chmod 775 suggested in another post do not work in this case. Any help on resolving this issue is greatly appreciated.

/storage/highspeed/EMT/WRFv4.1.2-ifc/WPS > ./ungrib.exe
Segmentation fault (core dumped)
/storage/highspeed/EMT/WRFv4.1.2-ifc/WPS >


Thank you for your time,

Elliot Tardif

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: Ungrib segmentation fault

Post by kwerner » Wed Jan 08, 2020 9:11 pm

Hi Elliot,
Can you attach your ungrib.log file, as well as your namelist.wps? Thanks!
NCAR/MMM

elliottardif
Posts: 12
Joined: Tue Jan 07, 2020 4:52 pm

Re: Ungrib segmentation fault

Post by elliottardif » Thu Jan 09, 2020 1:45 pm

Hi kwerner, I have attached the namelist.wps file to this reply. I do not have an ungrib.log file because none was produced before the segmentation fault occurred.

Thank you,

Elliot Tardif
Attachments
namelist.wps
(1.35 KiB) Downloaded 28 times

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: Ungrib segmentation fault

Post by kwerner » Thu Jan 09, 2020 8:26 pm

Elliot,
Thanks for sending that. I don't see anything out of the ordinary in your namelist that would cause a segmentation fault.
1) Were you able to run geogrid without any problems?
2) Can you attach a couple of time periods of your input data so that I can try to run the case with your namelist?
3) Will you please also attach your configure.wps file and your WPS compile log so that I can check how it was compiled?
NCAR/MMM

elliottardif
Posts: 12
Joined: Tue Jan 07, 2020 4:52 pm

Re: Ungrib segmentation fault

Post by elliottardif » Fri Jan 10, 2020 8:00 pm

Good afternoon kwerner, here are my answers to your questions.

1. I am able to run geogrid with no issues.
2. I am using operational NAM data from NCEP (link: https://nomads.ncep.noaa.gov/pub/data/n ... /nam/prod/). The .grib2 files themselves are ~60M apiece so I don't think I'd be able to attach them here. You may download a couple files from nomads and drop them in.
3. I have attached the requested files to this reply for your review.

Thank you,

Elliot Tardif
Attachments
log.compile
(89.68 KiB) Downloaded 21 times
configure.wps
(3.28 KiB) Downloaded 23 times

elliottardif
Posts: 12
Joined: Tue Jan 07, 2020 4:52 pm

Re: Ungrib segmentation fault

Post by elliottardif » Tue Jan 14, 2020 10:08 pm

One other point of note: I am able to run earlier versions of WRF (e.g., 3.9) using the same configuration with no problem.

Thank you,

Elliot Tardif

kwerner
Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: Ungrib segmentation fault

Post by kwerner » Tue Jan 21, 2020 5:40 pm

Hi Elliot,
I'm not sure exactly which files you used for your run. There are so many different ones listed in each of the links from the NAM directory (from the link you sent). You could try to package a couple files up and attach them here. If they are too large, see the home page of this forum for information on submitting large files. It would be helpful if I was using the exact files you are just to be sure. T'hanks!
NCAR/MMM

mgduda
Posts: 374
Joined: Mon Feb 26, 2018 7:35 pm

Re: Ungrib segmentation fault

Post by mgduda » Mon Feb 03, 2020 11:37 pm

Although the NAM data are in GRIB2 format, it's likely that ungrib isn't even getting to the point of trying to open one of the GRIB files if the segmentation fault occurs before ungrib even creates an ungrib.log file. In this case, it might be worth trying to clean and reconfigure the WPS without GRIB2 support in order to test whether it is the JasPer, PNG, or libz libraries that might be interacting badly with the v4.1 ungrib code.
NCAR/MMM

elliottardif
Posts: 12
Joined: Tue Jan 07, 2020 4:52 pm

Re: Ungrib segmentation fault

Post by elliottardif » Thu Feb 06, 2020 10:09 pm

Good afternoon, my apologies for the delay in responding. I will try configuring WPS and see if that helps. If not then I will send some large files from my test.

Thanks all for your help!

Elliot Tardif

elliottardif
Posts: 12
Joined: Tue Jan 07, 2020 4:52 pm

Re: Ungrib segmentation fault

Post by elliottardif » Tue Jun 16, 2020 7:07 pm

Good afternoon, I wanted to put a period on this effort. I was never able to get ungrib working on v4.1.2, so I downloaded v4.2 and it now works fine. I am thinking it was a version-specific issue. Thanks to everyone for their help.

Best,

Elliot Tardif

Post Reply

Return to “ungrib”