Modified ERA-Interim data: calc_ecmwf_p.exe warning messages

Topics related to running the ungrib.exe program
Post Reply
Posts: 10
Joined: Fri Feb 14, 2020 11:17 pm

Modified ERA-Interim data: calc_ecmwf_p.exe warning messages

Post by edougherty » Wed Jun 17, 2020 8:20 pm

Hi all,

I am trying to run WRF with modified ERA-I data (i.e., I added a perturbation to the original data). When I ran WRF using the unmodified ERA-I data, following instructions from ... d-era.html, it worked fine, including the calc_ecmwf_p program.

Despite outputting the perturbed ERA-I data in what appears to be the same format as the original (including grib formatting, grib codes, and zaxis types), I get the following error when I run calc_ecmwf_p.exe:

Code: Select all

Reading from FILE at time 2007-05-09_12
Found SOILHGT field in FILE:2007-05-09_12
Found PSFC field in FILE:2007-05-09_12
 WARNING First level is missing!
 WARNING No available level found near level           59 !
This warning appears for all levels (59 down to 2), and at each time. However, the program still outputs 'PRES' files that output GHT, RH, and PRESSURE at each model level (see attached 'PRES' file).
(76.34 KiB) Downloaded 18 times
My namelist.wps file is also attached here:
(1.95 KiB) Downloaded 17 times
If you could please let me know how to solve this issue with calc_ecmwf_p.exe, I'd appreciate it.

Posts: 1926
Joined: Wed Feb 14, 2018 9:21 pm

Re: calc_ecmwf_p.exe error

Post by kwerner » Tue Jun 23, 2020 4:13 pm

To start, you can try running rd_intermediate.exe (found in the utils directory) on the original ERA-I intermediate files and then again on the intermediate files produced from the modified ERA-I data. You can then look for obvious differences in the contents of the two sets of intermediate files.

Post Reply

Return to “ungrib”