(RESOLVED) No executables after registry modifications

All topics related to compiling WRF, including environment set-up, and library installation
Post Reply
jayesatvik
Posts: 9
Joined: Thu Jan 21, 2021 3:34 pm

(RESOLVED) No executables after registry modifications

Post by jayesatvik » Thu Feb 04, 2021 2:32 pm

Hi,

I changed the registry.em_common file to get SWDDNI, SWDDIF output and ran the followng commands in the main WRF directory to recompile

./clean -a
export J="-j 1"
./configure
./compile em_real >& log.compile

But I am not getting executable files after recompile. The compile log file for the compilation error, WRF configuration file and the modified registry files are attached.

Request for assistance.
Attachments
configure.wrf
WRF configuration file
(20.36 KiB) Downloaded 8 times
Registry.EM_COMMON
EM Common Registry File
(393.72 KiB) Downloaded 8 times
log.compile
Log Compile File
(598.98 KiB) Downloaded 11 times

jayesatvik
Posts: 9
Joined: Thu Jan 21, 2021 3:34 pm

Re: No executables after recompile

Post by jayesatvik » Fri Feb 05, 2021 2:58 pm

I request someone to please help me with this problem.

Thanks

jayesatvik
Posts: 9
Joined: Thu Jan 21, 2021 3:34 pm

Re: No executables after recompile

Post by jayesatvik » Mon Feb 08, 2021 4:24 pm

The culprit was Ubuntu.. I reinstalled Ubuntu, reinstalled library and recompiled without error. I'll run the test model now. Thanks everyone for the support.

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: No executables after recompile

Post by kwerner » Mon Feb 08, 2021 9:40 pm

Hi,
I would like to apologize for the delay. I was out of the office last week and am trying to get caught up now. Thank you for your patience.
I'm glad you were able to figure out the problem and move forward! Thank you very much for updating the post.
NCAR/MMM

Post Reply

Return to “WRF Compiling/Installation”