Problem with SST_INPUT

Topics specifically related to the wrf.exe program
Post Reply
maR_Kus
Posts: 9
Joined: Mon Dec 21, 2020 1:24 pm

Problem with SST_INPUT

Post by maR_Kus » Tue Dec 22, 2020 6:32 pm

Hi All,

I am performing some simulations with WRF and I am able to complete the runs without any error. However, looking at the output I realized that SST_INPUT contains all constant zero-values, although I have correct values into wrflowinp_d01.
I am using these flags into the namelist to update the SSTs every 6 hours:

auxinput4_inname = "wrflowinp_d<domain>",
auxinput4_interval = 360,

sst_update = 1,
sst_skin = 1,

Looking at the rsl.out the model reads the file:

Input data is acceptable to use: wrflowinp_d01
Input data processed for aux input 4 for domain 1

Besides, the variable SST contains realistic time-varying SSTs as does SSTSK. Am I missing something here or the model can reproduce SSTs even if it does not read them correct? Otherwise could it be just an issue while writing data? I am facing this problem with both version 3.8.1 and 4.2.
Thank you in advance for anyone who could help me figure out what is going wrong!
Markus

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: Problem with SST_INPUT

Post by Ming Chen » Tue Dec 22, 2020 8:13 pm

Markus,

Would you please double check your wrflowinp file and make sure that SST is correct and time-varying?

If SST is correct, please remove the option sst_skin = 1, then rerun this case and let me know whether SST is reasonable in your wrfout file.
WRF Help Desk

maR_Kus
Posts: 9
Joined: Mon Dec 21, 2020 1:24 pm

Re: Problem with SST_INPUT

Post by maR_Kus » Wed Dec 23, 2020 2:41 pm

Hi Ming,
thanks for the quick reply.
I double checked the wrflowinp file and it has correct time-varying SSTs, as displayed in the attached figure.
I also re-ran the model with sst_skin = 0, but it does not fix the issue. Any other suggestions? The odd part is that SSTs from wrfout have realistic values, so I guess the models is reading/using them correctly.
Attachments
wrflowinp_SST.png
SST from wrflowinp
wrflowinp_SST.png (7.58 KiB) Viewed 117 times

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: Problem with SST_INPUT

Post by Ming Chen » Wed Dec 23, 2020 6:05 pm

I looked at the codes related to SST_INPUT. It turns out that this variable is only used when the compiling option key_cpp_oasis3 is turned on.
This option intends to hook WRF with OASIS ocean model. At present, we don't use this option.
This is why INPUT_SST is always zero. Please let me know if you have more questions.
WRF Help Desk

maR_Kus
Posts: 9
Joined: Mon Dec 21, 2020 1:24 pm

Re: Problem with SST_INPUT

Post by maR_Kus » Wed Dec 23, 2020 6:57 pm

Hi Ming, thanks for the clarification, that makes sense.

ntmanhvn181
Posts: 47
Joined: Thu Jul 04, 2019 4:07 am

Re: Problem with SST_INPUT

Post by ntmanhvn181 » Fri Jan 15, 2021 10:55 am

Hi Ming,
I also ran the WRF simulation with the OISST data updating option, however when I run the wrf.exe program it got the error which is attached in the attachments:
WRF NUMBER OF TILES = 1
d02 2014-07-05_00:00:00 297 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 323 550 10 vert_cfl,w,d(eta)= 11555.64 2457077. 3.6130250E-02
d02 2014-07-05_00:00:00 2 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 183 397 6 vert_cfl,w,d(eta)= 2.125179 119.5028 1.8969357E-02
d02 2014-07-05_00:00:00 7 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 301 460 6 vert_cfl,w,d(eta)= 2.958751 163.8605 1.8969357E-02
Timing for main: time 2014-07-05_00:00:20 on domain 2: 45.42154 elapsed seconds
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
wrf.exe 000000000305879A for__signal_handl Unknown Unknown
libpthread-2.17.s 00002B8382D425D0 Unknown Unknown Unknown
wrf.exe 0000000002C31E41 Unknown Unknown Unknown
wrf.exe 0000000002C2D3B4 Unknown Unknown Unknown
wrf.exe 0000000002C2AFB3 Unknown Unknown Unknown
wrf.exe 00000000024BB5B0 Unknown Unknown Unknown
wrf.exe 0000000001CE8B5E Unknown Unknown Unknown
wrf.exe 0000000001487367 Unknown Unknown Unknown
wrf.exe 000000000129DC50 Unknown Unknown Unknown
wrf.exe 000000000056630F Unknown Unknown Unknown
wrf.exe 0000000000566926 Unknown Unknown Unknown
wrf.exe 00000000004160D1 Unknown Unknown Unknown
wrf.exe 000000000041608F Unknown Unknown Unknown
wrf.exe 0000000000416022 Unknown Unknown Unknown
libc-2.17.so 00002B8382F71495 __libc_start_main Unknown Unknown
wrf.exe 0000000000415F29 Unknown Unknown Unknown
Please help to address this problem.
Thank you in advance.
Bests,
Manh,
Attachments
WRF.err.txt
(65.49 KiB) Downloaded 2 times
namelist.input.txt
(4.71 KiB) Downloaded 3 times

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: Problem with SST_INPUT

Post by Ming Chen » Wed Jan 20, 2021 10:16 pm

CFL violation indicates the model became numerically unstable. If you turn off set_update, I suppose the model can run successfully. If so, this definitely indicates that your SST data is wrong. Please double check to make sure it is reasonable, and the landsea mask is correct.
WRF Help Desk

Post Reply

Return to “wrf.exe”