forrtl: severe (174): SIGSEGV, segmentation fault occurred

Topics specifically related to the wrf.exe program
Post Reply
ntmanhvn181
Posts: 47
Joined: Thu Jul 04, 2019 4:07 am

forrtl: severe (174): SIGSEGV, segmentation fault occurred

Post by ntmanhvn181 » Fri Jan 15, 2021 8:40 am

Hi everyone,
I'm trying to run WRF simulation with the SST updating option. My SST input is the NOAA Optimum Interpolation 1/4 Degree Daily Sea Surface Temperature Analysis.
I use the netcdf-to-intermediate.f program to convert the SST data to the intermediate form and run metgrid program.
Then, I run the real program to create the bdy and ini conditions, but I have a the error "Not enough info for a p sfc computation". I add the following flag in the "domains" section of the namelist.input file and it worked.
"sfcp_to_sfcp = .true."
Unfortunately, when I ran the wrf program, it failed. My error is displayed in the below:
WRF NUMBER OF TILES = 1
d02 2014-07-05_00:00:00 5 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 324 572 6 vert_cfl,w,d(eta)= 2.524988 129.8792 1.8969357E-02
d02 2014-07-05_00:00:00 5 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 301 460 6 vert_cfl,w,d(eta)= 2.453524 133.1831 1.8969357E-02
d02 2014-07-05_00:00:00 98 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 323 548 8 vert_cfl,w,d(eta)= 102.2177 1693.051 2.7248859E-02
d02 2014-07-05_00:00:00 2 points exceeded cfl=2 in domain d02 at time 2014-07-05_00:00:00 hours
d02 2014-07-05_00:00:00 MAX AT i,j,k: 183 397 6 vert_cfl,w,d(eta)= 2.089354 117.4065 1.8969357E-02
Timing for main: time 2014-07-05_00:00:20 on domain 2: 24.22685 elapsed seconds
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
wrf.exe 000000000305879A for__signal_handl Unknown Unknown
libpthread-2.17.s 00002B9AD9E8B5D0 Unknown Unknown Unknown
wrf.exe 0000000002C31E41 Unknown Unknown Unknown
wrf.exe 0000000002C2D3B4 Unknown Unknown Unknown
wrf.exe 0000000002C2AFB3 Unknown Unknown Unknown
wrf.exe 00000000024BB5B0 Unknown Unknown Unknown
wrf.exe 0000000001CE8B5E Unknown Unknown Unknown
wrf.exe 0000000001487367 Unknown Unknown Unknown
wrf.exe 000000000129DC50 Unknown Unknown Unknown
wrf.exe 000000000056630F Unknown Unknown Unknown
wrf.exe 0000000000566926 Unknown Unknown Unknown
wrf.exe 00000000004160D1 Unknown Unknown Unknown
wrf.exe 000000000041608F Unknown Unknown Unknown
wrf.exe 0000000000416022 Unknown Unknown Unknown
libc-2.17.so 00002B9ADA0BA495 __libc_start_main Unknown Unknown
wrf.exe 0000000000415F29 Unknown
Please help to solve this problem.
Thank you in advance!
Bests,
manh,

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurred

Post by Ming Chen » Fri Jan 15, 2021 7:15 pm

Manh,
CFL violation indicates the model integration is not stable, which can be attributed to many reasons.
(1) The max time step is 6 times of grid interval. Please check to make sure it is correct.
(2) If you turn off SST update, can the model run successfully?
(3) If you run with SST from the dataset you ungrib to drive the model, can the model run successfully?
WRF Help Desk

ntmanhvn181
Posts: 47
Joined: Thu Jul 04, 2019 4:07 am

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurred

Post by ntmanhvn181 » Sat Jan 16, 2021 3:37 am

Hi Ming,
I can run model successfully without updating sst data. And in my case, the sst data is updated at every 00Z, so i have many warnings of missing data at 06Z, 12Z, 18Z. So this is my error, isn't it?
Can you kindly help me to solve this problem?
Thank you very much!

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurred

Post by Ming Chen » Wed Jan 20, 2021 9:38 pm

SST update can be done at daily intervals. In this case, you need to set auxinput4_interval = 1440. I don't think this is the issue that gives you the CFL violation.
I am suspicious that your SST data may not be correct.Please examine your input data, make sure it is reasonable, and make sure the lands mask is correct.
WRF Help Desk

ntmanhvn181
Posts: 47
Joined: Thu Jul 04, 2019 4:07 am

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurred

Post by ntmanhvn181 » Sat Jan 23, 2021 2:00 pm

Hi Ming,
I think you are right. Although I could convert the SST data from the NC file to the intermediate for running the metgrid program, but the wrf.exe program couldn't work.
Besides, I use the python program in the link (https://github.com/nasa/podaac_tools_an ... dataset.py) to acquire the sst data. Can you kindly give me some websites to download the SST data and the years between 2014 and 2020 are good for my case.
Thank you very much!
Bests,
manh,

Ming Chen
Posts: 1290
Joined: Mon Apr 23, 2018 9:42 pm

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurred

Post by Ming Chen » Tue Jan 26, 2021 3:56 pm

Manh,
We don't archive NOAA SST data here in NCAR. We usually recommend people to contact NOAA for information related to their data and download procedure. With so many data products provided by different agencies, it is hard for us to get familiar with various datasets. NCAR CISL archived some of those data, but not all of them.
WRF Help Desk

Post Reply

Return to “wrf.exe”