emitted longwave <0; skin T may be wrong due to inconsistent input of SHDFAC with LAI

Topics/questions specifically related to WRF model physics
Post Reply
figurski
Posts: 18
Joined: Fri Oct 12, 2018 6:38 am
Location: Gdansk University of Technology
Contact:

emitted longwave <0; skin T may be wrong due to inconsistent input of SHDFAC with LAI

Post by figurski » Wed Apr 28, 2021 12:35 pm

Dear all,

I am using dwscaling WRF 4.2.2 dynamic scaling with a horizontal resolution of 12.5, 2.5 and 0.5 km. Preliminary data are from a GFS 0.25 deg model. I have been using the same parameterization for several months and for several days I have received the error that was already described earlier.

viewtopic.php?t=9661

In my case it is similar, after a few minutes of work, the model ends with the following message:

emitted longwave <0; skin T may be wrong due to inconsistent
input of SHDFAC with LAI
116 44 SHDFAC= 0.5681409 VAI= 4.333785 TV=
285.6632 TG= 274.1017
LWDN= 199.5439 FIRA= -236.5735 SNOWH= 0.0000000E+00
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 2096
STOP in Noah-MP
-------------------------------------------

In the previous post, the problem was solved by disabling the adaptive time step. In my simulations, I do not use the adaptive time step, so the problem is still open.
Please let me know how this problem can be solved.

My namelist.input

&physics
mp_physics = 6, 6, 6, 6,
ra_lw_physics = 24, 24, 24, 24,
ra_sw_physics = 24, 24, 24, 24,
radt = 10, 10, 10, 10,
slope_rad = 1, 1, 1, 1,
topo_shading = 1, 1, 1, 1,
sf_sfclay_physics = 91, 91, 91, 91,
sf_surface_physics = 4, 4, 4, 4,
bl_pbl_physics = 7, 7, 7, 7,
bldt = 0, 0, 0, 0,
cu_physics = 14, 0, 0, 0,
cudt = 0, 0, 0, 0,
sf_lake_physics = 0, 0, 0, 0,
lakedepth_default = 50., 50., 50., 50., 50.,
lake_min_elev = 5., 5., 5., 5., 5.,
use_lakedepth = 1,
do_radar_ref = 1,
sst_skin = 0,
swint_opt = 2,
mp_zero_out = 0,
sst_update = 1,
levsiz = 59,
paerlev = 29,
cam_abs_dim1 = 4,
cam_abs_dim2 = 40,
isfflx = 1,
ifsnow = 0,
icloud = 1,
surface_input_source = 1,
num_soil_layers = 4,
num_land_cat = 21,
sf_urban_physics = 0, 0, 0, 0,
!num_urban_layers = 400,
maxiens = 1,
maxens = 3,
maxens2 = 3,
maxens3 = 16,
ensdim = 144,
cu_rad_feedback = .true., .false., .false., .false.,
cu_diag = 0, 0, 0, 0,
hail_opt = 0,
hailcast_opt = 0, 1, 0, 0,
haildt = 10,
prec_acc_dt = 60, 60, 60, 60,
bl_mynn_tkeadvect = .false., .false., .false., .false.,
bl_mynn_tkebudget = 0, 0, 0, 0,
/

&noah_mp
opt_snf = 4,
/

&dynamics
w_damping = 1,
diff_opt = 1, 1, 1, 1,
km_opt = 4, 4, 4, 4,
diff_6th_opt = 0, 0, 0, 0,
diff_6th_factor = 0.12, 0.12, 0.12, 0.12,
base_temp = 290,
epssm = 0.3,
damp_opt = 0,
zdamp = 5000.0, 5000.0, 5000.0, 5000.0,
dampcoef = 0.2, 0.2, 0.2, 0.2,
khdif = 0, 0, 0, 0, 0,
kvdif = 0, 0, 0, 0, 0,
non_hydrostatic = .true., .true., .true., .true., .true.,
moist_adv_opt = 1, 1, 1, 1, 1,
scalar_adv_opt = 1, 1, 1, 1, 1,
/



Best regards
Mariusz

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: emitted longwave <0; skin T may be wrong due to inconsistent input of SHDFAC with LAI

Post by kwerner » Thu Apr 29, 2021 11:26 pm

This post has been moved to the physics section, as the error you are receiving is specific to WRF physics. Someone will respond to your inquiry soon.
NCAR/MMM

Post Reply

Return to “WRF Physics”