Community Land Model LSM with seabreeze2d_x

Topics related to running an idealized case
Post Reply
andreazonato
Posts: 4
Joined: Fri Sep 11, 2020 3:28 pm

Community Land Model LSM with seabreeze2d_x

Post by andreazonato » Fri Sep 11, 2020 3:30 pm

Dear all,

I'm trying to run idealized simulations with the CLM surface scheme (option 5), starting with a initial soil moisture of 0.2. However, soil moisture lows to values of 1e-5 after the first time step, and soil liquid water doesn't evolve,i. e. It remains constant to 0.2 during the whole Period of simulation.

Any suggestion to solve this problem?

Thank you in advance for your help.

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by kwerner » Mon Sep 14, 2020 9:41 pm

Hi,
Can you let me know which version of the model you are using? Thanks!
NCAR/MMM

andreazonato
Posts: 4
Joined: Fri Sep 11, 2020 3:28 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by andreazonato » Wed Sep 23, 2020 6:48 am

Hi,
I'm using version 4.1.2.

Thank you!

Andrea

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by kwerner » Mon Sep 28, 2020 4:28 pm

Andrea,
Have you tested this with other surface schemes? I'd just like to verify that this is specific to the CLM scheme. Will you also please attach the namelist.input file you're using? Thanks!
NCAR/MMM

andreazonato
Posts: 4
Joined: Fri Sep 11, 2020 3:28 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by andreazonato » Tue Sep 29, 2020 2:10 pm

Hi,
I tested even others LSM, and they work giving reasonable values of soil moisture.

That's my namelist:

&time_control
run_days = 0,
run_hours = 36,
run_minutes = 0,
run_seconds = 0,
start_year = 2015,
start_month = 03,
start_day = 20,
start_hour = 18,
start_minute = 00,
start_second = 00,
end_year = 2015,
end_month = 06,
end_day = 23,
end_hour = 18,
end_minute = 00,
end_second = 00,
history_interval = 30,
history_begin_h = 12,
frames_per_outfile = 1000,
restart = .false.,
restart_interval = 3000,
iofields_filename = "remove_variables.txt",
io_form_history = 2,
io_form_restart = 2,
io_form_input = 2,
io_form_boundary = 2,
debug_level = 0,
/

&domains
time_step = 0,
time_step_fract_num = 60,
time_step_fract_den = 10,
max_dom = 1,
s_we = 1,
e_we = 101,
s_sn = 1,
e_sn = 201,
s_vert = 1,
ztop = 12329.,
dx = 1000,
dy = 1000,
e_vert = 65,

&physics
mp_physics = 0,
ra_lw_physics = 1,
ra_sw_physics = 1,
radt = 5,
sf_sfclay_physics = 1,
sf_surface_physics = 5,
bl_pbl_physics = 8,
sf_urban_physics = 0,
bldt = 0,
tracer_pblmix = 0,
cu_physics = 0,
cudt = 0,
num_soil_layers =10,
/

&fdda
/

&dynamics
m_opt = 0,
hybrid_opt = 2,
rk_ord = 3,
diff_opt = 2,
km_opt = 4,
damp_opt = 3,
dampcoef = .1,
zdamp = 10000.,
khdif = 300.,
kvdif = 0.,
c_s = 0.18,
c_k = 0.10,
mix_isotropic = 1,
smdiv = 0.1,
emdiv = 0.01,
epssm = 0.1,
time_step_sound = 6,
h_mom_adv_order = 5,
v_mom_adv_order = 3,
h_sca_adv_order = 5,
v_sca_adv_order = 3,
mix_full_fields = .true.,
non_hydrostatic = .true.,
pert_coriolis = .true.,
use_theta_m = 1,

/

/

&bdy_control
periodic_x = .false.,
symmetric_xs = .true.,
symmetric_xe = .true.,
open_xs = .false.,
open_xe = .false.,
periodic_y = .false.,
symmetric_ys = .true.,
symmetric_ye = .true.,
open_ys = .false.,
open_ye = .false.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/

$ideal
ideal_case = 8
/




Thanks!

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by kwerner » Tue Oct 06, 2020 3:51 pm

I tested this and got the same problem. I spoke to our group's physics specialist about it and they said the seabreeze case is hardwired with 4 soil levels and CLM needs more than 4 to run correctly. You may be able to search the code and modify it to make a change, but I'm not exactly sure where. I would start with the dyn_em/module_initialize_ideal.F to see if you can find anything.
NCAR/MMM

Xiaoxingyun
Posts: 25
Joined: Thu Nov 19, 2020 12:39 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by Xiaoxingyun » Thu Nov 19, 2020 1:24 pm

kwerner wrote:
Tue Oct 06, 2020 3:51 pm
I tested this and got the same problem. I spoke to our group's physics specialist about it and they said the seabreeze case is hardwired with 4 soil levels and CLM needs more than 4 to run correctly. You may be able to search the code and modify it to make a change, but I'm not exactly sure where. I would start with the dyn_em/module_initialize_ideal.F to see if you can find anything.
Hi,

But I find that the default num_soil_layers is 5 in WRF3.8.1. Does it mean that the soil layers can be adjusted for different land surface scheme?

Besides, could you help me to have a check if the em_les case is also hardwired or not? Because I can successfully run it with thermal diffusion scheme, but get an error when I use Noah scheme. (The error is forrtl: severe (66): output statement overflows record, unit -5, file Internal List-Directed Writ). If it is also a problem related to the num_soil_layers, is there any WRF version that can be used to run the em_les ideal case with Noah scheme?

Many thanks in advance.

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by kwerner » Thu Nov 19, 2020 11:16 pm

@Xiaoxingyun,
Yes, LSMs can have their own number of soil layers. You can read more about this in the WRF Users' Guide.

As for your second question - as it's somewhat of a different topic, can you start a new forum post with that question? We like to keep topics separate to help with future searchability. Thanks!
NCAR/MMM

Xiaoxingyun
Posts: 25
Joined: Thu Nov 19, 2020 12:39 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by Xiaoxingyun » Fri Nov 20, 2020 1:57 am

kwerner wrote:
Thu Nov 19, 2020 11:16 pm
@Xiaoxingyun,
Yes, LSMs can have their own number of soil layers. You can read more about this in the WRF Users' Guide.

As for your second question - as it's somewhat of a different topic, can you start a new forum post with that question? We like to keep topics separate to help with future searchability. Thanks!
Hi,

Thank you very much for your reply.
I am afraid I did not express quite clearly last time. I find the num_soil_layers is 5 in the default namelist of the seabreeze2d_x ideal case in WRF3.8.1, so I am wondering if the seabreeze2d_x ideal case is not hardwired with 4 soil levels in WRF3.8.1?

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by kwerner » Fri Nov 20, 2020 4:48 pm

Xiaoxingyun,
It looks like the default number of levels several versions ago (e.g., V3.8.1) was 5 for num_soil_layers; however, that was adjusted. Take a look at this code commit that explains this.
NCAR/MMM

Xiaoxingyun
Posts: 25
Joined: Thu Nov 19, 2020 12:39 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by Xiaoxingyun » Fri Nov 20, 2020 11:14 pm

kwerner wrote:
Fri Nov 20, 2020 4:48 pm
Xiaoxingyun,
It looks like the default number of levels several versions ago (e.g., V3.8.1) was 5 for num_soil_layers; however, that was adjusted. Take a look at this code commit that explains this.
Thanks a lot!

Xiaoxingyun
Posts: 25
Joined: Thu Nov 19, 2020 12:39 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by Xiaoxingyun » Sat Nov 21, 2020 12:00 am

kwerner wrote:
Thu Nov 19, 2020 11:16 pm
@Xiaoxingyun,
Yes, LSMs can have their own number of soil layers. You can read more about this in the WRF Users' Guide.

As for your second question - as it's somewhat of a different topic, can you start a new forum post with that question? We like to keep topics separate to help with future searchability. Thanks!
Thank you! I have created 2 new forum posts about my questions!

Xiaoxingyun
Posts: 25
Joined: Thu Nov 19, 2020 12:39 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by Xiaoxingyun » Thu Dec 03, 2020 11:34 am

andreazonato wrote:
Fri Sep 11, 2020 3:30 pm
Dear all,

I'm trying to run idealized simulations with the CLM surface scheme (option 5), starting with a initial soil moisture of 0.2. However, soil moisture lows to values of 1e-5 after the first time step, and soil liquid water doesn't evolve,i. e. It remains constant to 0.2 during the whole Period of simulation.

Any suggestion to solve this problem?

Thank you in advance for your help.

Hi andreazonato,

I am wondering if you also modified the land use types (lu_index) in this ideal case, and could you possibly give me some suggestions about how to modify lu_index?
Many thanks in advance!

Xiaoxingyun
Posts: 25
Joined: Thu Nov 19, 2020 12:39 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by Xiaoxingyun » Thu Dec 03, 2020 11:41 am

andreazonato wrote:
Fri Sep 11, 2020 3:30 pm
Dear all,

I'm trying to run idealized simulations with the CLM surface scheme (option 5), starting with a initial soil moisture of 0.2. However, soil moisture lows to values of 1e-5 after the first time step, and soil liquid water doesn't evolve,i. e. It remains constant to 0.2 during the whole Period of simulation.

Any suggestion to solve this problem?

Thank you in advance for your help.

In addition, how do you set the initial soil moisture? Thanks a lot!

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Community Land Model LSM with seabreeze2d_x

Post by kwerner » Wed Jan 27, 2021 6:47 pm

@Xiaoxingyun,
Hi, as this was posted a while back, I wanted to see if you were able to obtain answers to your questions yet. If not, please let me know what questions you still have. Thanks!
NCAR/MMM

Post Reply

Return to “Idealized Cases”