Sigma levels

Topics related to the ARWpost post-processor
Post Reply
JCollins
Posts: 52
Joined: Thu Aug 23, 2018 11:01 am

Sigma levels

Post by JCollins » Thu Jul 18, 2019 11:24 am

I have a WRF output file in which the sigma levels are indicated by the eta_levels option of the namelist.input. They are 28 levels.

In the namelist.ARWpost option "0" is marked in "interp_method". ARWpost runs successfully.

When I use Grads and open the file it prints "LEV set to 1 1" and if I execute it, it prints "zdef 27 linear 1 1".

If I want to set height with "set lev" I can not put any, because the sigma levels set in WRF do not appear.

I am doing something wrong?

Thanks.

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Sigma levels

Post by kwerner » Thu Jul 18, 2019 3:57 pm

Hi,
Do you think this problem is related to something missing in the WRF output, something not being done correctly in ARWpost, or is this a GrADS problem? We don't support GrADS here, and I don't know much about it, so I'm having trouble following the part related to that. Can you explain in a little more detail about what you are seeing versus what you expect to see? Can you also let me know which version of WRF you are using, and which version of ARWpost? Thanks.
NCAR/MMM

JCollins
Posts: 52
Joined: Thu Aug 23, 2018 11:01 am

Re: Sigma levels

Post by JCollins » Thu Jul 18, 2019 4:05 pm

I understand that it is not a Grads problem. Nor do I think it is a WRF problem (version 4.1), since you can see that there are 28 levels. I think it may be related to the interpolation form of ARWpost (version 3.1). If I choose option 1 and indicate the levels that I want to remove, it does so without error and the file is read correctly. On the other hand, with the option 0 to determine the sigma of the WRF output file, it is not able to do so.

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Sigma levels

Post by kwerner » Tue Jul 30, 2019 10:01 pm

Can you attach one of the wrfout_d01* files you are using, along with your namelist.input file for running WRF, and your namelist.ARWpost file? Thanks!
NCAR/MMM

jaya_t
Posts: 1
Joined: Thu Apr 04, 2019 7:23 am

Re: Sigma levels

Post by jaya_t » Wed Oct 23, 2019 7:44 am

Dear all,

I also am facing a similar situation. I have my e_vert=30 in the namelist.input and no eta_levels defined. After post-processing using ARW-post with interp_method=0, my zdef shows 24 linear 1 1. Can someone please explain why this 24 is seen for default setting in ARWpost. Also, what are these 24 corresponding to. Is there any way of defining AGL pressure or altitude levels using ARWpost? Thanks.

Jaya

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Sigma levels

Post by kwerner » Thu Oct 24, 2019 7:47 pm

Jaya,
Can you attach one of the wrfout_d01* files you are using, along with your namelist.input file for running WRF, and your namelist.ARWpost file? Thanks!
NCAR/MMM

Post Reply

Return to “ARWpost”