ARWpost runing very slow.Help!

Topics related to the ARWpost post-processor
Post Reply
sinisters93
Posts: 43
Joined: Thu Apr 25, 2019 9:25 pm

ARWpost runing very slow.Help!

Post by sinisters93 » Mon Nov 16, 2020 12:23 pm

I am running ./ARWpost.exe and it is taking for like 45 min to process just one single hour data. However, it was fast for some previous runs that I have made.

This data is running for like 4 hours from now and it has to go for like 365 days, it would take ages.

Can anybody help how to resolve this?
Processors are working fine because my other jobs are running very nicely.
---------------------------------------------------------------------------------------------------------------------------
!!!!!!!!!!!!!!!!
ARWpost v3.1
!!!!!!!!!!!!!!!!

FOUND the following input files:
/scratch/sahir/largefile/WRF_MET/WRFV3/run/wrfout_d01_2018-01-01_00:00:00

START PROCESSING DATA

Processing time --- 2018-01-01_00:00:00
Found the right date - continue

Processing time --- 2018-01-01_01:00:00
Found the right date - continue

Processing time --- 2018-01-01_02:00:00
Found the right date - continue

Processing time --- 2018-01-01_03:00:00
Found the right date - continue

Processing time --- 2018-01-01_04:00:00
Found the right date - continue

Processing time --- 2018-01-01_05:00:00
Found the right date - continue

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: ARWpost runing very slow.Help!

Post by kwerner » Mon Nov 16, 2020 5:54 pm

Hi,
Is this data file much larger or higher-resolution than the previous ARWpost runs you have done? If not, then this is probably related to your system or environment. Is it possible something changed there? Were any libraries updated? Are you sharing space with others who may be taking up a lot of the processing space? Are you running other things that could impact this? Unfortunately, it's something you will likely need to discuss with your systems administrator at your institution.
NCAR/MMM

sinisters93
Posts: 43
Joined: Thu Apr 25, 2019 9:25 pm

Re: ARWpost runing very slow.Help!

Post by sinisters93 » Mon Nov 16, 2020 10:13 pm

I am using 8x8km grid and e_we=101 and e_sn=101. time_step=48
start=01/01/2018
end=31/12/2018

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: ARWpost runing very slow.Help!

Post by kwerner » Mon Nov 16, 2020 10:17 pm

8x8km is a pretty high resolution. Were you using something much more coarse before when ARWpost was running faster?
NCAR/MMM

sinisters93
Posts: 43
Joined: Thu Apr 25, 2019 9:25 pm

Re: ARWpost runing very slow.Help!

Post by sinisters93 » Tue Nov 17, 2020 12:18 am

before i used 2x2 km and 4x4km

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: ARWpost runing very slow.Help!

Post by kwerner » Tue Nov 17, 2020 1:41 am

I see. Unfortunately the speed of the run is most likely related to your particular system or environment settings. As I advised before, you will need to discuss the problem with a systems administrator at your institution. They will hopefully be able to track down the difference between the current runtime speed and the previous speed.
NCAR/MMM

Post Reply

Return to “ARWpost”