Problem at Installation

Any miscellaneous question/problem/comment related to WRF support that does not fit under any of the other category
Post Reply
sauravshuvo
Posts: 9
Joined: Mon Mar 11, 2019 6:11 pm

Problem at Installation

Post by sauravshuvo » Wed May 08, 2019 6:32 am

Dear Sir/Madam,
I want to install the WRF-Hydro. I have installed Netcdf_C, Netcdf_F and Mpich. Whenver I compile, it does not work for me - no .exe files are produced. I have added my compilation log with this. My bash files have these in it -

export CC="gcc"
export CXX="g++"
export FC="gfortran"
export FCFLAGS="-m64"
export F77="gfortran"
export FFLAGS="-m64"
export NETCDF="/usr/local/netcdf"
export NETCDF_INC="/usr/local/netcdf/include"
export NETCDF_LIB="/usr/local/netcdf/lib"
export NETCDF=/usr/local/netcdf
export PATH=$NETCDF/bin:$PATH
export LDFLAGS=-L/usr/local/netcdf/lib
export CPPFLAGS=-I/usr/local/netcdf/include
export LD_LIBRARY_PATH=${NETCDF}/lib:${LD_LIBRARY_PATH}
export JASPERLIB=/usr/local/grib2/lib
export JASPERINC=/usr/local/grib2/include
export MPICH=/usr/local/mpich
export NETCDF_classic=0
#export WRF_EM_CORE=0
#export WRF_NMM_CORE=0
export WRF_HYDRO=1
export HYDRO_D=1
export SPATIAL_SOIL=1
export WRF_HYDRO_RAPID=0
export WRFIO_NCD_LARGE_FILE_SUPPORT=1
export NCEP_WCOSS=0
export WRF_HYDRO_NUDGING=1
ulimit -s unlimited

What should I do now? Please help.

-Saurav
Attachments
log.compile
(37.14 KiB) Downloaded 33 times

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Problem at Installation

Post by kwerner » Wed May 08, 2019 3:53 pm

Hi,
This forum is for Basic WRF, WRFDA, WRF-Chem, and MPAS. To obtain support for the WRF-Hydro model, please visit this website:
https://ral.ucar.edu/projects/wrf_hydro/overview
NCAR/MMM

sauravshuvo
Posts: 9
Joined: Mon Mar 11, 2019 6:11 pm

Re: Problem at Installation

Post by sauravshuvo » Sun May 12, 2019 11:49 am

Dear Sir,
I have mailed them, but did not get any response yet.
I am in really a very bad situation with this. Any help in this regard, would be greatly appreciated.
I have tried a few things, still I get these errors.
I know it's not the place and it's really rude to ask again.
But, can anybody help me in this regard?
Attachments
compile.log
(45.95 KiB) Downloaded 37 times

meteoadriatic
Posts: 27
Joined: Thu Apr 25, 2019 12:42 pm

Re: Problem at Installation

Post by meteoadriatic » Sun May 12, 2019 3:04 pm

Saurav,

Your error is this:

Code: Select all

/bin/sh: 1: mpif90: not found
So, compile script cannot find mpi fotran compiler. It is either:
- not in your path, or
- not built at all

So as you said you did compiled mpich, then I assume that it is not in your path. Concentrate your efforts in fixing that so that your compile script can find mpif90.

Looking at your first post, I see this:
export MPICH=/usr/local/mpich

assuming, your mpich installation is in /usr/local/mpich

but, you have
export PATH=$NETCDF/bin:$PATH

and I can't see any reference of setting mpich directory as part of PATH. As /usr/local/mpich is not standard part of PATH on linux, you need to add it. For example, try to add this also in your script:
export PATH=/usr/local/mpich:$PATH

or, if your mpif90 is located in /usr/local/mpich/bin (maybe?) then instead of above, add
export PATH=/usr/local/mpich/bin:$PATH

Or any path wherever it is located...

Hope this helps,
Ivan

sauravshuvo
Posts: 9
Joined: Mon Mar 11, 2019 6:11 pm

Re: Problem at Installation

Post by sauravshuvo » Sun May 12, 2019 7:10 pm

Dear Sir,
It worked!!!
Thank you so much!!!
I can't tell you how releieving it feels!!!
Thank you again!!!
Sincerely -
Saurav

Post Reply

Return to “Miscellaneous”