(RESOLVED) map_utils_module.f syntax compiling error of OBSGRID

Topics related to the OBSGRID utility
Post Reply
haohe1982
Posts: 2
Joined: Tue Nov 17, 2020 7:55 pm

(RESOLVED) map_utils_module.f syntax compiling error of OBSGRID

Post by haohe1982 » Tue Nov 17, 2020 8:10 pm

I tried to re-compiled the OBSGRID due to the update of the Linux OS. WRF and WPS were successfully compiled with ifort and icc 19.1.1 and related netCDF library. When I tried to compile OBSGRID, the follow error shows

**** Compiling oa ****

/bin/rm -f map_utils_module.o map_utils_module.mod
/lib/cpp -I. -C -P -DDEC -traditional map_utils_module.F90 > map_utils_module.f
ifort -FR -convert big_endian -c map_utils_module.f -I/lustre/haohe/CMAQv5.3.1/lib/netcdf/include
map_utils_module.f(1): error #5082: Syntax error, found '/' when expecting one of: <LABEL> <END-OF-STATEMENT> ; <IDENTIFIER> TYPE MODULE ELEMENTAL IMPURE NO$
/* Copyright (C) 1991-2018 Free Software Foundation, Inc.

I search it on-line, it is related to the free format. I didn't meet this problem in the old OS. So I think something new could cause this error. Attached please find my configure.oa. Any comments or suggestions are highly appreicated.

Hao
Attachments
configure.oa.txt
(1.69 KiB) Downloaded 13 times

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Compiling error of OBSGRID

Post by kwerner » Thu Nov 19, 2020 11:39 pm

Hao,
Take a look at this forum post that provides a fix for this. Let me know if that works for you.
NCAR/MMM

haohe1982
Posts: 2
Joined: Tue Nov 17, 2020 7:55 pm

Re: Compiling error of OBSGRID

Post by haohe1982 » Fri Nov 20, 2020 10:09 pm

It solved the problem. Thanks a lot for your kind help.

Hao

kwerner
Posts: 2287
Joined: Wed Feb 14, 2018 9:21 pm

Re: Compiling error of OBSGRID

Post by kwerner » Mon Nov 23, 2020 6:33 pm

Great! Thank you for letting me know.
NCAR/MMM

Post Reply

Return to “OBSGRID”