Issue with v3 v4 data for WRF4.2.1 and Ndown.exe

Post Reply
pgoddard
Posts: 11
Joined: Fri Aug 14, 2020 7:40 pm

Issue with v3 v4 data for WRF4.2.1 and Ndown.exe

Post by pgoddard » Mon Mar 29, 2021 4:54 pm

Hello,

I did post about this topic a couple weeks ago, but I thought I would provide some more details to whomever can help. (old post: https://forum.wrfforum.com/viewtopic.ph ... 8899517410)

I am running WRF 4.2.1, and WPS 4.2. I recently updated the WRF preprocessors as well as I now use v4 for the geostatic data. I am using the EDGAR-HTAP v2 data from https://edgar.jrc.ec.europa.eu/htap_v2/ and the anthro_emiss executable from https://www.acom.ucar.edu/wrf-chem/download.shtml

I can run the real.exe for my coarse grid with the namelist option force_use_old_data set equal to false. However, when I try to run wrf.exe I get an error (also see the attached d01_rsl.error.0000, I also attached the namelist.input used at the time of executing wrf.exe):

d01 2014-08-27_00:00:00 Input data is acceptable to use: wrflowinp_d01
d01 2014-08-27_00:00:00 Input data processed for aux input 4 for domain 1
mediation_integrate: med_read_wrf_chem_emissions: Open file wrfchemi_00z_d01
HOURLY EMISSIONS UPDATE TIME 0.0 0.0
mediation_integrate: med_read_wrf_chem_emissions: Read emissions for time 2014-08-27_00:00:00
d01 2014-08-27_00:00:00 Error trying to read metadata
d01 2014-08-27_00:00:00 File name that is causing troubles = wrfchemi_00z_d01
d01 2014-08-27_00:00:00 You can try 1) ensure that the input file was created with WRF v4 pre-processors, or
d01 2014-08-27_00:00:00 2) use force_use_old_data=T in the time_control record of the namelist.input file
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 332
---- ERROR: The input file appears to be from a pre-v4 version of WRF initialization routines
-------------------------------------------
Rank 0 [Mon Mar 22 14:59:39 2021] [c0-0c2s1n2] application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
forrtl: error (76): Abort trap signal


I think I am doing the necessary steps to use only WRF v4 data and pre-processors, but if there is any step someone thinks I may have missed, I would be grateful for any troubleshooting ideas.

I can run wrf.exe if I set the namelist option force_use_old_data set equal to true. And the simulation runs properly and provides output for my coarse domain. However, when I run my inner domain with ndown.exe inner domain, the wrf.exe will halt with the following error:

SIMULATION START DATE = 2014-08-27_00:00:00
Timing for processing wrfinput file (stream 0) for domain 1: 9.64600 elapsed seconds
Max map factor in domain 1 = 1.04. Scale the dt in the model accordingly.
D01: Time step = 30.00000 (s)
D01: Grid Distance = 9.000000 (km)
D01: Grid Distance Ratio dt/dx = 3.333333 (s/km)
D01: Ratio Including Maximum Map Factor = 3.466527 (s/km)
D01: NML defined reasonable_time_step_ratio = 6.000000
---- WARNING : Older v3 input data detected
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 684
---- Error : Cannot use moist theta option with old data
-------------------------------------------
Rank 0 [Mon Mar 22 17:44:11 2021] [c4-0c0s6n1] application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
forrtl: error (76): Abort trap signal

I do not know if this is associated with the v3 – v4 error from above. But, looking at the wrf_bdy files before and after the ndown.exe step, the T_BTYE variable looks quite different. The range of this temperature tendency changes from ~ -50 to 50 k/s to ~ 100 to 5230 k/s. The latter values are noticeably incorrect (I attached a screen shot of the variable from wrf_bdy before and after ndown.exe).

I did see this post, https://forum.wrfforum.com/viewtopic.php?f=7&t=11255, which looks like a similar issue to mine. But, from what I can tell, the issue was resolved(?) by WRF version 4.2.1.

For the second part of my question, I also attached the namelist.input and error output, noted by “d02” in the file names



Thank you for your time and help,
Paul
wrf_bdy_T_BTYE_before_ndown.PNG
wrf_bdy_T_BTYE_after_ndown.PNG
wrf_bdy_T_BTYE_after_ndown.PNG (17.27 KiB) Viewed 220 times
Attachments
d02_rsl.error.0000.txt
(3.01 KiB) Downloaded 3 times
d02_namlist.input
(22.97 KiB) Downloaded 12 times
d01_rsl.error.0000.txt
(43.34 KiB) Downloaded 3 times
d01_orig_namelist.input
(23 KiB) Downloaded 6 times

jordanschnell
Posts: 141
Joined: Thu Feb 27, 2020 10:58 pm

Re: Issue with v3 v4 data for WRF4.2.1 and Ndown.exe

Post by jordanschnell » Mon Mar 29, 2021 11:45 pm

Hi Paul,

I am unsure about the first part of your question - since you are creating pre-v4 data, you must set the force_use_old_data = T. As for your ndown error, it likely is coming from this namelist option: "use_theta_m" in the &dynamics namelist, which is by default = 1; i.e. the error "Error : Cannot use moist theta option with old data". Try setting the option to 0.

Jordan

pgoddard
Posts: 11
Joined: Fri Aug 14, 2020 7:40 pm

Re: Issue with v3 v4 data for WRF4.2.1 and Ndown.exe

Post by pgoddard » Tue Mar 30, 2021 6:23 pm

Hi Jordan,

Thank you for your help. Sorry if I was not clear with my first question. I was just curious to which step of mine may be using v3 data -- even though I think I am using the most up-to-date version of the preprocessors and geo-static data.

Though, I posed the first question in case it was associated with the ndown error with respect to the moist theta option. But, if setting use_theta_m equal to 0 resolves my issue with ndown, then I did need to worry about the first question.

I will try a ndown in the coming days and let you know how it goes.

Thanks again,
Paul

Post Reply

Return to “Running”