Why aren’t certain variables showing in my UPP output?

Inquiries or comments related to the Unified Post Processor

Moderators: NCAR/SOLAR, NCAR/UPP

Post Reply
hertneky
Posts: 63
Joined: Tue May 12, 2020 4:18 pm

Why aren’t certain variables showing in my UPP output?

Post by hertneky » Wed Jun 03, 2020 5:42 pm

Why aren’t certain variables showing in my UPP output?

hertneky
Posts: 63
Joined: Tue May 12, 2020 4:18 pm

Re: Why aren’t certain variables showing in my UPP output?

Post by hertneky » Mon Sep 28, 2020 8:29 pm

There are a number of possibilities as to why a field you requested cannot be found in the UPP output.

1. It is possible that the field you are trying to request is dependent on the core (e.g. ARW, FV3, NMM).

2. Certain fields can be dependent on model configuration, such as physics choices.

3. A variable may be missing from your WRF output that is required for outputting the requested field.

4. While most variables use the standard WMO table, some use the NCEP table and this needs to be specified in the configuration file. To determine if your variable needs this table specification, you can reference the UPPV4.1/parm/params_grib2_tbl_new file. This table lists the discipline, category, parameter number, table info, and variable. If the value for table info (column 4) is "1", then it requires the NCEP table to be specified. While we have tried to include this in the parm/post_avblflds.xml file for the fields that require it, some fields have been missed. To add this yourself, you will need to add the following line to the parameter block for the specific field in the post_avblflds.xml file: <table_info>NCEP</table_info>

5. For simulated satellite products, it may be that your domain is not covered by the field of view of the satellite instrument.

It is important to know your data and what you are expecting from the output. We will continue to try to update the user guide as often as possible to reflect limitations, additions, and changes in output fields.

Post Reply

Return to “UPP”