Compile Error in WRFV4.4 moving nest option

ben108472

New member
Describe the bug
When I compile WRFV4.4, same error is repeated.
module_comm_dm_4.G:30:0: fatal error: REGISTRY_COMM_DM_PERIOD_subs.inc: No such file or directory

To Reproduce
nohup ./compile em_real &>compile.log
 

Attachments

  • compile.log
    1.4 MB · Views: 4

kwerner

Administrator
Staff member
Hi,
I've not seen this particular error previously, but from a search online I was able to find this older post to a different forum. This indicates the issue could be due to running out of memory. Can you check on that, and perhaps see if that post is helpful at all?

If that isn't the issue, can you confirm whether the problem still exists when using the latest version of the code (V4.4) and when using a basic nesting option?
 

ben108472

New member
Hi,
I've not seen this particular error previously, but from a search online I was able to find this older post to a different forum. This indicates the issue could be due to running out of memory. Can you check on that, and perhaps see if that post is helpful at all?

If that isn't the issue, can you confirm whether the problem still exists when using the latest version of the code (V4.4) and when using a basic nesting option?
Basic option (option=1) can be successfully complied. I think the problem is not out of memory because memory is sufficient (more than 50GB).
 

kwerner

Administrator
Staff member
Thanks for trying that. Did you try to compile the moving nest option with V4.4 of the WRF code?
 

kwerner

Administrator
Staff member
I just tested this and I'm seeing the same problem. Let me work on this a bit and get back to you. Thank you for your patience.
 

kwerner

Administrator
Staff member
Hi,
Apologies for the delay. This error has taken quite a bit of time to track down. I have a temporary fix for you to try. We will talk to our software engineers to see if we can figure out a long-term solution, but for now, this one should suffice as long as you have gcc installed. If so, please try the following.

./clean -a
./configure
Then edit the configure.wrf file. Look for the following two lines and change them from "icc" to "gcc."
Code:
SCC             =       gcc
CCOMP           =       gcc
and then look for this line and change "-ip" to "-c"
Code:
CFLAGS_LOCAL    =       -w -O3 -c -DRPC_TYPES=1 #-xHost -fp-model fast=2 -no-prec-div -no-prec-sqrt -ftz -no-multibyte-chars # -DRSL0_ONLY
Save the configure.wrf file and then try to compile again. Please let me know if this works for you so that I can add an FAQ about it, if so. Thanks!
 
Top