Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

compiling WRF - a lot of errors, do not know which is fatal

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Klara_353

New member
Hello,
I am compiling WRF3.8.1 for real cases on Ubuntu; however, no executable files where created after the compilation.
I checked the compile.log file (attached), but there are so many error messages that I do not understand what was the fatal problem.
Could please anyone have look if you could figure out what was the fatal calling?
Thank you very much in advance.
 

Attachments

  • compile (1).log
    653.1 KB · Views: 54
Hi Klara,
I understand. The errors can be a bit overwhelming. Typically the first error ('Error' with a capital 'E') that you come to in the log file is the one causing the problem; however, this is only certainly true when only 1 processor is used to compile the code. The default is to use 2 processors, so can you set the following so that it will only compile with one (csh e.g.):
Code:
setenv J "-j 1"

You will also need to issue a 'clean -a' and then reconfigure the code, and then recompile. I still expect the compile to fail, so when it does, please send your new compile log, along with your configure.wrf file.

Thanks,
Kelly
 
Hi Kelly,
thank you very much for your help.
I have tried all of these commands you suggested and finally even the setting it to just one processor worked.
./compile, however, stopped almost immediately.
I enclose both the files that could be useful, but now there is just one error: "No rule to make target 'real_em'."
During the process I was following this tutorial: https://www.enviroware.com/installing-and-running-wrf-3-8-on-linux-ubuntu-lts-16-04-with-intel-i7-8-core-cpu/, as all the commands from this tutorial seemed to do the job, well - down to ./compile.
Thank you for your help again, I really appreciate it.
Klara
 

Attachments

  • compile.log
    853 bytes · Views: 49
  • configure.wrf
    20.3 KB · Views: 51
Hi,
Although in your original compile log, this wasn't a problem, now it looks like you don't have the mandatory standard unix command "make" available. I would suggest following our compiling tutorial page for proper installation of the libraries and the model. You can find that here:
http://www2.mmm.ucar.edu/wrf/OnLineTutorial/compilation_tutorial.php

Even though you have already followed the steps to try to compile this, start fresh with brand new directories so as to not overlap anything you previously did. Follow this word-for-word to ensure a better chance of building the model. Unfortunately, if you are unable to get past the first section (e.g., not having the mandatory unix commands installed on your system), that will be something you need to discuss with the systems administrator at your institution, as it's related to your particular environment.
 
Hello,
I have been trying to do it all again according to the official tutorial and all library instalations and tests went well.
I also tried to run it on just 1 processor, but there still are errors...
So I am including the two files you suggested might give a clue about what is happening. I just did not know
what was meant by "built log" as at the end of the compile.log it was recommended to check it.
Could you please have a look to see what is the problem? I do not understand why it is not working to me. :(
I realized that an important information might be that I run it on Ubuntu under Windows machine, but in this
tutorial installing WRF on Ubuntu: https://github.com/camposdelano/configuring-wrf-3.8-on-ubuntu-server-16.04 they did exactly all
the things necessary according to the official tutorial, yet my results are different.
Thank you very much for any advice.
Best regards,
Klara
 

Attachments

  • compile_1proc.log
    74 KB · Views: 54
  • configure_1proc.wrf
    20.3 KB · Views: 44
Hi,

just a short update: I tried to make it compile with 1 processor and serial (option 32 for configuration) and now I am getting "only" 7 fatal errors:

"Can´t open module file 'module_cu_g3.mod' for reading at (1): No such file or directory, compilation terminated." 4-times
"Can´t open module file 'module_cumulus_driver.mod' for reading at (1): No such file or directory, compilation terminated."
"Can´t open module file 'module_first_rk_step_part1.mod' for reading at (1): No such file or directory, compilation terminated."
"Can´t open module file 'module_physics_init..mod' for reading at (1): No such file or directory, compilation terminated."

And I truly cannot find them, I do not know why they were not compiled, but I will go on trying to find out...

Thanks for any comments.
Klara
 

Attachments

  • compile_32.log
    684.6 KB · Views: 51
  • configure_32.wrf
    20.3 KB · Views: 48
One last thing:
I found this website http://forum.wrfforum.com/viewtopic.php?f=5&t=10930 and I tried the solution with replacing the lines in module_cu_g3.F posted by Kevin Thomas, but the result was stil the same errors.
 
Hi Klara,
The "build log" is simply the log file that you are writing your compile output to (e.g., compile_32.log). If you open that up and do a search for "Error" (with a capital 'E'), the error shown is:

Code:
module_cu_g3.f90:3132:41:

                    call random_seed (PUT=seed)
                                         1
Error: Size of ‘put’ argument of ‘random_seed’ intrinsic at (1) too small (12/33)

The solution to this particular error is addressed here:
http://forum.mmm.ucar.edu/phpBB3/viewtopic.php?f=37&t=217&p=482&hilit=random_seed#p482

Kelly
 
Top