Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error opening wrfbdy_01 after 296 successful restarts

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Dear WRF Help,

I'm running four simulations each with four nested domains. Three of them are performing nicely, but one of them has suddenly given the error:

med_latbound_in: error opening wrfbdy_d01 for reading. IERR = -1021

I'm not sure what is happening because the spatial boundaries have, of course, not changed at all and the time extent accounted for in the Time variable is complete and goes for much longer that where the simulation is now. I've tried to Google the error and have not found any information about how to address it. What do I need to do to figure out what has gone wrong?

How long did the model run before it crashed? if you type ncdump -v Times wrfbdy_d01, does it yield time that cover the integration period?
If so, the error message might be misleading and something else actually resulted in the model failure. Please examine wrfout right before it crashed, and see whether something weird showed in the simulation.
Thanks very much, Ming.

I'm wondering now if there was just some glitch with the computer on which the simulation was running because for some reason, when I tried the simulation again today to make sure I had a reasonable set of error messages so that I could take your advice, the simulation ran as if there had never been an issue. If it happens again, though, I'll make sure to check wrfout to see what that might be able to tell me!

I am running WRF V 4.0 model on rhel 7.6
I am trying to run WRFDA with 4d var technique to assimilate radiance data. As per the guidebook, I have done all the settings including setting up of RTTOV library and crtm_coeffs as well.

When I am trying to run da_wrfvar.exe, I am getting error as rsl.error.0000 file

The output of rsl.out.0000 is also attached

As per my understanding, we dont need copy the wrfbdy_d01 file in build folder to run da_wrfvar.exe

For reference, I have attached namelist.input file.

Request help me to resolve this issue.

Thanks !!


  • namelist_input.txt
    4.7 KB · Views: 19
  • rslout.txt
    997 bytes · Views: 14
  • rslerror.txt
    962 bytes · Views: 16