Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error running WRF-Chem

etmolina95

New member
Hello
Been trying to resolve this error issue by looking for answers somewhere else in the internet, but to no avail.
I am running WRF-Chem with anthropogenic emissions from EDGAR-HTAP and bio emissions from MEGAN, all the tools necessary before running WRF-CHEM, such as anthro_emis, megan_bio_emiss, and mozbc are successfully ran, but an error comes when I execute wrf.exe using four or eight processors. This is typically the error message:
===================================================================================
= BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
= PID 4422 RUNNING AT meteo14-virtual-machine
= EXIT CODE: 9
= CLEANING UP REMAINING PROCESSES
= YOU CAN IGNORE THE BELOW CLEANUP MESSAGES
===================================================================================
YOUR APPLICATION TERMINATED WITH THE EXIT STRING: Killed (signal 11)
This typically refers to a problem with your application.
Please see the FAQ page for debugging suggestions

I am using a virtual machine to run my WRF simulations, I also have an Ubuntu desktop that run such simulations, but both have this error message. I would appreciate any response towards resolving this issue. I attached here my namelist.input and rsl.error files. Thank you very much.
 

Attachments

  • namelist.input
    5.9 KB · Views: 32
  • rsl.error.0003.txt
    39.6 KB · Views: 13
Hello @jordanschnell ,
I am also experiencing the same issue when running WRF-Chem with MOZART-MOSAIC, including the aqueous phase chemistry option (chem_opt=202). Also, in addition, some warning messages are coming in rsl files like the following:
Timing for main: time 2015-12-22_00:20:00 on domain 2: 277.93716 elapsed seconds
Timing for main: time 2015-12-22_00:20:00 on domain 1: 1434.27002 elapsed seconds

d01 Domain average of dpsdt, dmudt (mb/3h): 20.0000000 14.1025238 10.2168245
d01 Max mu change time step: 81 131 5.54984144E-04
d01 Domain average of dardt, drcdt, drndt (mm/sec): 20.0000000 3.95910433E-07 3.77430865E-07 1.84796356E-08
d01 Domain average of rt_sum, rc_sum, rnc_sum (mm): 20.0000000 1.85023309E-04 1.79915369E-04 5.10797008E-06
d01 Max Accum Resolved Precip, I,J (mm): 1.38865774E-02 16 186
d01 Max Accum Convective Precip, I,J (mm): 0.525469244 97 71
d01 Domain average of sfcevp, hfx, lh: 20.0000000 3.29568945E-02 9.58207893 70.6290131
calculate MEGAN emissions at ktau, gmtp, tmidh = 21 0.00000000 0.341666669
newnucbb mins 2.33E+02 5.00E-02 1.00E-22 5.00E-23 5.00E-23 0.00E+00
newnucbb maxs 3.02E+02 9.80E-01 9.03E-11 1.00E-22 1.40E-21 0.00E+00
newnucbb avgs 2.63E+02 4.12E-01 7.38E-13 5.06E-23 1.66E-22 0.00E+00
newnucbb hinuc 0.00E+00 0.00E+00 0.00E+00 0.00E+00 0.00E+00 0.00E+00
newnucbb dtnuc 6.00E+01
newnucbb ncnt 39032 0 0 0 0 0 0
coagbb ncntaa 39032 0 47355 22 85695 0 4 60218 0 4
coagbb ncntbb1 15836 17938 17686 18137 184 16996 17143 10100 13074 10461
coagbb ncntbb2 182 181 252 181 181 17550 17550 17550 17550 17550
coagbb ncntbb3 17550 17550 17550 17550 17550 0 4089 181
-------------------------
WARNING: Large total lw optical depth of ******** at point i,j,nb= 1 1 1
Diagnostics 1: k, tauaerlw1, tauaerlw16
1 0.00 0.00
2 0.00 0.00
3****************
4****************
5****************
6****************
7****************
8 0.00 0.00
9 0.00 0.00
10 0.00 0.00
11 0.00 0.00
12****************
13****************
14****************
15****************
16****************
17****************
18****************
19****************
2029210.94********
21 121.24 788.67
22 13.10 88.81
23 0.00 0.00
24 0.00 0.00
25 0.00 0.00
26 0.00 0.00
27 0.00 0.00
28 0.00 0.00
29 0.00 0.00
30 0.00 0.00
31 0.00 0.00
32 0.00 0.00
33 0.00 0.00
34 0.00 0.00
-------------------------
-------------------------

The above warning messages are printed several times in the 'rsl.error.000' file. The following warnings are printed 'rsl.out.0000' file:
Timing for main: time 2015-12-22_00:00:12 on domain 2: 226.56436 elapsed seconds
d02 Domain average of dpsdt, dmudt (mb/3h): 0.200000003 166.734070 36.3811378
d02 Max mu change time step: 284 337 5.28227771E-03
d02 Domain average of dardt, drcdt, drndt (mm/sec): 0.200000003 1.10129272E-09 0.00000000 1.10129272E-09
d02 Domain average of rt_sum, rc_sum, rnc_sum (mm): 0.200000003 1.96605860E-08 0.00000000 1.96605860E-08
d02 Max Accum Resolved Precip, I,J (mm): 9.99416006E-05 392 298
d02 Max Accum Convective Precip, I,J (mm): 0.00000000 240024080 771529424
d02 Domain average of sfcevp, hfx, lh: 0.200000003 4.10684152E-04 5.31190109 49.8655281
calculate MEGAN emissions at ktau, gmtp, tmidh = 2 0.00000000 5.00000035E-03
entering mosaic_cloudchem_driver - ktau = 2
leaving mosaic_cloudchem_driver - ktau = 2 0

ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200

Also, a 'fort.67' file generated containg the same line " ASTEM internal steps exceeded 200"
I am giving a test run with two domains (d01:20 km and d02:4 km) with one-way nesting by setting 'feedback' option to '0' for just 2 days. The WRF-Chem ran successfully when I used the MOZCART option (chem_opt=112) and MOSART-MOSAIC (chem_opt=201). But, these errors are only occurring for chem_opt=202. I checked a previous post (Possible Bug with MOZART-MOSAIC scheme while writing output), there you also suggested to set
&chem
mozart_ph_diag=1
However, in that case, the WRF-Chem version was from V4.3 to V4.4.2, while my version is 3.9.1. So, is it the solution for my case, too? I have tried to include this option in the "&chem" section, but even real.exe didn't run (after linking the emission files and before running mozbc). I checked Registry/registry.chem, but I didn't find any options there. So, I really doubt that this would work for the earlier versions.
I am attaching my 'namelist.input', 'wrfrun.log', 'module_mosaic_cloudchem.F', 'module_mosaic_driver.F' and 'module_mosaic_therm.F' files for my version.
Can you please take a look at these and let me know the solution for my case? I have been really struggling with this 'chem_opt=202' option for the last few months, and I haven't found any solutions yet after trying so many test runs. So, I will be very grateful if you kindly help me to solve this issue.
Thanks and regards,
Ankan
 

Attachments

  • module_mosaic_cloudchem.txt
    51.4 KB · Views: 4
  • module_mosaic_driver.txt
    593.6 KB · Views: 3
  • module_mosaic_therm.txt
    517.3 KB · Views: 3
  • namelist.input_chemopt202.txt
    8.4 KB · Views: 7
  • wrfrun.log.txt
    1.9 KB · Views: 1
Last edited:
Hello @jordanschnell ,
I am also experiencing the same issue when running WRF-Chem with MOZART-MOSAIC, including the aqueous phase chemistry option (chem_opt=202). Also, in addition, some warning messages are coming in rsl files like the following:
Timing for main: time 2015-12-22_00:20:00 on domain 2: 277.93716 elapsed seconds
Timing for main: time 2015-12-22_00:20:00 on domain 1: 1434.27002 elapsed seconds

d01 Domain average of dpsdt, dmudt (mb/3h): 20.0000000 14.1025238 10.2168245
d01 Max mu change time step: 81 131 5.54984144E-04
d01 Domain average of dardt, drcdt, drndt (mm/sec): 20.0000000 3.95910433E-07 3.77430865E-07 1.84796356E-08
d01 Domain average of rt_sum, rc_sum, rnc_sum (mm): 20.0000000 1.85023309E-04 1.79915369E-04 5.10797008E-06
d01 Max Accum Resolved Precip, I,J (mm): 1.38865774E-02 16 186
d01 Max Accum Convective Precip, I,J (mm): 0.525469244 97 71
d01 Domain average of sfcevp, hfx, lh: 20.0000000 3.29568945E-02 9.58207893 70.6290131
calculate MEGAN emissions at ktau, gmtp, tmidh = 21 0.00000000 0.341666669
newnucbb mins 2.33E+02 5.00E-02 1.00E-22 5.00E-23 5.00E-23 0.00E+00
newnucbb maxs 3.02E+02 9.80E-01 9.03E-11 1.00E-22 1.40E-21 0.00E+00
newnucbb avgs 2.63E+02 4.12E-01 7.38E-13 5.06E-23 1.66E-22 0.00E+00
newnucbb hinuc 0.00E+00 0.00E+00 0.00E+00 0.00E+00 0.00E+00 0.00E+00
newnucbb dtnuc 6.00E+01
newnucbb ncnt 39032 0 0 0 0 0 0
coagbb ncntaa 39032 0 47355 22 85695 0 4 60218 0 4
coagbb ncntbb1 15836 17938 17686 18137 184 16996 17143 10100 13074 10461
coagbb ncntbb2 182 181 252 181 181 17550 17550 17550 17550 17550
coagbb ncntbb3 17550 17550 17550 17550 17550 0 4089 181
-------------------------
WARNING: Large total lw optical depth of ******** at point i,j,nb= 1 1 1
Diagnostics 1: k, tauaerlw1, tauaerlw16
1 0.00 0.00
2 0.00 0.00
3****************
4****************
5****************
6****************
7****************
8 0.00 0.00
9 0.00 0.00
10 0.00 0.00
11 0.00 0.00
12****************
13****************
14****************
15****************
16****************
17****************
18****************
19****************
2029210.94********
21 121.24 788.67
22 13.10 88.81
23 0.00 0.00
24 0.00 0.00
25 0.00 0.00
26 0.00 0.00
27 0.00 0.00
28 0.00 0.00
29 0.00 0.00
30 0.00 0.00
31 0.00 0.00
32 0.00 0.00
33 0.00 0.00
34 0.00 0.00
-------------------------
-------------------------

The above warning messages are printed several times in the 'rsl.error.000' file. The following warnings are printed 'rsl.out.0000' file:
Timing for main: time 2015-12-22_00:00:12 on domain 2: 226.56436 elapsed seconds
d02 Domain average of dpsdt, dmudt (mb/3h): 0.200000003 166.734070 36.3811378
d02 Max mu change time step: 284 337 5.28227771E-03
d02 Domain average of dardt, drcdt, drndt (mm/sec): 0.200000003 1.10129272E-09 0.00000000 1.10129272E-09
d02 Domain average of rt_sum, rc_sum, rnc_sum (mm): 0.200000003 1.96605860E-08 0.00000000 1.96605860E-08
d02 Max Accum Resolved Precip, I,J (mm): 9.99416006E-05 392 298
d02 Max Accum Convective Precip, I,J (mm): 0.00000000 240024080 771529424
d02 Domain average of sfcevp, hfx, lh: 0.200000003 4.10684152E-04 5.31190109 49.8655281
calculate MEGAN emissions at ktau, gmtp, tmidh = 2 0.00000000 5.00000035E-03
entering mosaic_cloudchem_driver - ktau = 2
leaving mosaic_cloudchem_driver - ktau = 2 0

ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200
ASTEM internal steps exceeded 200

Also, a 'fort.67' file generated containg the same line " ASTEM internal steps exceeded 200"
I am giving a test run with two domains (d01:20 km and d02:4 km) with one-way nesting by setting 'feedback' option to '0' for just 2 days. The WRF-Chem ran successfully when I used the MOZCART option (chem_opt=112) and MOSART-MOSAIC (chem_opt=201). But, these errors are only occurring for chem_opt=202. I checked a previous post (Possible Bug with MOZART-MOSAIC scheme while writing output), there you also suggested to set
&chem
mozart_ph_diag=1
However, in that case, the WRF-Chem version was from V4.3 to V4.4.2, while my version is 3.9.1. So, is it the solution for my case, too? I have tried to include this option in the "&chem" section, but even real.exe didn't run (after linking the emission files and before running mozbc). I checked Registry/registry.chem, but I didn't find any options there. So, I really doubt that this would work for the earlier versions.
I am attaching my 'namelist.input', 'wrfrun.log', 'module_mosaic_cloudchem.F', 'module_mosaic_driver.F' and 'module_mosaic_therm.F' files for my version.
Can you please take a look at these and let me know the solution for my case? I have been really struggling with this 'chem_opt=202' option for the last few months, and I haven't found any solutions yet after trying so many test runs. So, I will be very grateful if you kindly help me to solve this issue.
Thanks and regards,
Ankan
@Ankan Can you please move this to a new thread? The Forum admins like to keep the issues separated if possible so that other users can search them easier.
 
Hello @Whatheway,
Sure. I will do that. I believe many WRF-Chem (version 3.9.1, not version >4) users are also struggling with this chemistry option, 'chem_opt=202' just like me. If this problem can be solved, then sure, it will also help those who will search for the solution here in the future. So, I will post this issue as a new thread, hoping that the problem will be solved soon. Thank you for replying back to me 😊.
With regards,
Ankan
 
Hi all,
I am running WRF-Chem version 4.4 and using chem-opt=202, and encountered the same problem:
ASTEM internal steps exceeded 200
and after some hours of simulation the model stopped.
I compiled the model using gfortran compiler. Now I want to install the model with intel compiler ( I would like to install WRF-Chem version 4.2.1 on a HPC. On HPC intel compiler has been installed before ( ifort version 19.0.4.243)) . But after setting the below environmental variables I cannot instal libpng and netcdf fortan, while I could install them using gfortran.
export CC=icc
export CXX=icpc
export FC=ifort
export F77=ifort
export F90=ifort
export MPIFC=mpiifort
export MPIF77=mpiifort
export MPIF90=mpiifort
export MPICC=mpiicc
export MPICXX=mpiicpc

So would you please advice me on how to sort this issue? What other environmental variables should be added, and also what changes should be considered regarding configure.wrf file please?

Thanks in advance,
best wishes,
 
Last edited:
Hi all,
I am running WRF-Chem version 4.4 and using chem-opt=202, and encountered the same problem:
ASTEM internal steps exceeded 200
and after some hours of simulation the model stopped.
I compiled the model using gfortran compiler. Now I want to install the model with intel compiler ( I would like to install WRF-Chem version 4.2.1 on a HPC. On HPC intel compiler has been installed before ( ifort version 19.0.4.243)) . But after setting the below environmental variables I cannot instal libpng and netcdf fortan, while I could install them using gfortran.
export CC=icc
export CXX=icpc
export FC=ifort
export F77=ifort
export F90=ifort
export MPIFC=mpiifort
export MPIF77=mpiifort
export MPIF90=mpiifort
export MPICC=mpiicc
export MPICXX=mpiicpc

So would you please advice me on how to sort this issue? What other environmental variables should be added, and also what changes should be considered regarding configure.wrf file please?

Thanks in advance,
best wishes,
Can you post a new thread in the forum please? The admins like to keep all the issues separate
 
Top