Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error with compiling the WRF model

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

pruthvi806

New member
Hello there,

I am new to linux and WRF model. To install the model have been following the YouTube tutorials (https://www.youtube.com/watch?v=hkLrdlQnKTw)

I am at the part where I have to compile the WRF model for the real case using the following two command:
Code:
 ./compile em_real > compile.log &
 tail -f compile.log

After running the second command I get the following error message:
Code:
 ==========================================================================
build started:   Tue Jul 14 17:14:26 EDT 2020
build completed: Tue Jul 14 17:14:38 EDT 2020

---> Problems building executables, look for errors in the build log  <---

==========================================================================
I have attached the full output from the terminal, if needed.

Have I configured it wrong or am I missing something?

Thanks
 

Attachments

  • Command_Output.txt
    61.7 KB · Views: 67
This topic has been moved to the WRF Compiling/Installation section, as it pertains to compiling the model. Someone will respond to your inquiry soon.
 
For reference, looks like the first error in the cascade is this:

time gfortran -o module_cu_g3.o -c -O2 -ftree-vectorize -funroll-loops -w -ffree-form -ffree-line-length-none -fconvert=big-endian -frecord-marker=4 -I../dyn_em -I../dyn_nmm -I/home/pruthvi/Build_WRF/WRFV3/external/esmf_time_f90 -I/home/pruthvi/Build_WRF/WRFV3/main -I/home/pruthvi/Build_WRF/WRFV3/external/io_netcdf -I/home/pruthvi/Build_WRF/WRFV3/external/io_int -I/home/pruthvi/Build_WRF/WRFV3/frame -I/home/pruthvi/Build_WRF/WRFV3/share -I/home/pruthvi/Build_WRF/WRFV3/phys -I/home/pruthvi/Build_WRF/WRFV3/chem -I/home/pruthvi/Build_WRF/WRFV3/inc -I/home/pruthvi/Build_WRF_LIBRARIES/netcdf/include module_cu_g3.f90
f951: Warning: Nonexistent include directory ‘/home/pruthvi/Build_WRF/WRFV3/chem’ [-Wmissing-include-dirs]
module_cu_g3.f90:3128:41:

3128 | call random_seed (PUT=seed)
| 1
Error: Size of ‘put’ argument of ‘random_seed’ intrinsic at (1) too small (12/33)
module_cu_g3.f90:3217:41:

3217 | call random_seed (PUT=seed)
| 1
Error: Size of ‘put’ argument of ‘random_seed’ intrinsic at (1) too small (12/33)
module_cu_g3.f90:3232:41:

3232 | call random_seed (PUT=seed)
| 1
Error: Size of ‘put’ argument of ‘random_seed’ intrinsic at (1) too small (12/33)
Command exited with non-zero status 1
0.09user 0.04system 0:00.17elapsed 80%CPU (0avgtext+0avgdata 17336maxresident)k
0inputs+0outputs (0major+4858minor)pagefaults 0swaps
make[3]: [../configure.wrf:338: module_cu_g3.o] Error 1 (ignored)
 
I guess you are working with an older version of WRF, probably before WRFV4.0? If so, can you update to newer version of WRF?
Anyway, please use the code I attached and try again. Let me know if you still have the same problem. Thanks.
 

Attachments

  • module_cu_g3_random_seed_fix.F.gz
    33.7 KB · Views: 122
Hey Ming,

I am very new to linux so I was following the tutorial I found online for WRF.

How do I run your code?

Thanks,
-Pruthvi
 
Top