Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ghg_input=1 and LW-SW radiation schemes pairing


New member
Dear all,

I am running some tests with the ghg_input=1 option (version 4.4). When I use the CAM LW radiation scheme in combination with the RRTM SW radiation scheme, I receive the following message during the real.exe execution:

"ERROR: ghg_input available only for these radiation schemes: CAM, RRTM, RRTMG, RRTMG_fast. And the LW and SW schemes must be reasonably paired together: OK = CAM LW with CAM SW. OK = RRTM, RRTMG LW or SW, RRTMG_fast LW or SW may be mixed." (This is coming from the module_check_a_mundo.F).

The above message seems to be a warning, as the real.exe execution is not being terminated; it proceeds normally with a "real_em: SUCCESS COMPLETE REAL_EM INIT" output in the end. Then, when I run wrf.exe I see the following information related to the ghg_option=1 option in the rsl.* files:

" GHG annual values from CAM trace gas file
Year = 2021, Julian day = 213
CO2 = 4.176698091542527E-004 volume mixing ratio ..."

So, can I assume that the model runs correctly with the ghg_option=1 option, despite the initial real.exe "error" (or warning) message? If this is not the case, maybe it would be better the above "error" to be fatal?

By the way, is there is a way to add CAM-related diagnostic fluxes (e.g., LWDNB) to the model output when I use RRTM or RRTMG radiation schemes? I tried using the "iofields_filename" option in the namelist, but I get warnings ( "Unable to modify mask for lwdnb").

Best regards,

The message is output to inform what radiation schemes can use the ghg_input option. It is not a 'warning' or 'error' message,
If you run the case with the following schemes: CAM, RRTM, RRTMG, RRTMG_fast, then yes the model runs correctly with the ghg_option=1 option.
LWDNB (and some other related variables like SWDNB etc.) should be available in wrfout if you run with CAM and RRTMG. But you need to modify the codes to add these variables if you run with RRTM.
Dear @Ming Chen,
I ran WRF-GHG with chem_opt = 17 for methane simulation. In this simulation, I used direct wetland and termite fluxes. However, after the simulation, I noticed that WRF-GHG only read termite emission fluxes and couldn't read wetland fluxes. I added this fluxes data using Auxinput = 15 port. Can you suggest how to incorporate this data into WRF-GHG?