Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

No change in background fields after assimilation (4dvar) of gps ztd data, even for singleob test

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I am trying to assimilate gps ztd data using 4dvar and cv option 3. WRF var runs successfully and wrfvar_output is created but there aren't any increments at all. To check if wrfda is working, I tried assimilating prepbufr data and wrfda worked fine with that data, there was a reasonable improvement in the fields. To check if there is some issue with my input data (which has been processed using obsproc), I tried running 3dvar with the data and then also I get an improvement in the fields. I then tried the single observation test with a pseudo_val of 5 for both 3dvar and 4dvar. While 3dvar successfully shows a change in the initial conditions, there was no change at all in the case of the single ob test for 4dvar.

I am not able to figure out what is going wrong. Please help me out!!