Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problem compiling WRFDA

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I have a problem compiling WRFDAV4.0. I am running Ubuntu 18.10. Prevously I compiled WRFDAV3.9.1 on Ubuntu 16.10 without any problem.
From V4.0 tarball I have been able to compile WRF and WPS. I compiled rttov122 with "make ARCH=gfortran emis_atlas", and also tried "make ARCH=gfortran all".. I am getting the same error with both WRFDAV4.0 and WRFDAV3.9.1.
I paste below contents of my compile.out, .bashrc and Makefile.local (for rttov122).
I will appreciate help.
copying Registry/Registry.wrfvar to Registry/Registry

Will compile with CRTM library

Compiling with RTTOV libraries in:

Can not find a compatible RTTOV library! Please ensure that your RTTOV build was successful,
your 'RTTOV' environment variable is set correctly, and you are using a supported version of RTTOV.
Currently supported versions are 11.1, 11.2, and 11.3

from bashrc
export WRF_EM_CORE=1
# export WRF_DIR=/home/zmumba/WRF

export BUFR=1
export CRTM=1
export RTTOV=$HOME/rttov122

From Makefile.local
Failed to paste text
Your rttov version is higher than required, using rttov 11.1-11.3 can help solve the problem.

The user guide emphasizes that "If satellite radiance data are to be used, a Radiative Transfer Model (RTM) is required. The current RTM versions that WRFDA supports are CRTM V2.2.3 and RTTOV V11.1–11.3 ".
You can find the refenrece from here

Thanks fecite for the useful inofrmation. After installing rttov112 I was able to compile WRFDA but minus the main executable. The compile.out gives a number of "undefined reference to `__rttov_hdf_mod_MOD_is_hdf.....'.
I will see what I can do