Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Real.exe output.

DWhitesel

New member
I noticed that when i used ncdump on my wrfinput files, there is only one time stamp for the output. When i go to dimensions, the times variable shows UNLIMITED ; // (1 currently). Is there a way to have it so real.exe generates the output to have the time stamps equal to the amount of metgrid files i feed into real.exe?

I am also curious if wrf.exe references any of my metgrid input as well.
 
Please set the namelist options:

all_ic_times = .true. (under &time_control),

Then rerun real.exe. Note that in this case you will have multiple wrfinput files corresponding to your met_em files.
 
Thank you for the help!

Is this option a single answer, or do I need to repeat it for multiple domains? I ran real with this option as a single answer, and it only worked for the first domain, but when i tried to repeat it for multiple domains, it would raise an error.
 

Attachments

  • namelist.input
    5.8 KB · Views: 3
  • rsl.out.0000
    3.6 MB · Views: 0
  • rsl.error.0000
    2.3 MB · Views: 1
Your RSL file indicates that this case runs successfully to the end. What errors did you see?

This option should work for all the model domains.
 
I received this error when i repeated the entry for all_ic_times:

module_io_quilt_old.F 2931 T
------ ERROR while reading namelist time_control ------
Maybe here?: io_form_boundary = 2,
Maybe here?: all_ic_times = .true.,.true.,
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 11082
ERRORS while reading one or more namelists from namelist.input.
-------------------------------------------

When I only filled the all_ic_times option once, this was my output.
 

Attachments

  • realexeoutput.png
    realexeoutput.png
    113.9 KB · Views: 1
If that is the case, then I may have a bug to report. Because I had filled that option once as you suggested, it only did all input times for the outer domain but not my inner domain.
 
Top