Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) "Unformatted file structure has been corrupted" with file rrpr.f90

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

gsh_uex_18

New member
Hi wrfhelp,

I need help with the following problem.

When I execute ./ungrib.exe I get the following error message:

INFORM: RRPR Processing : 2014-04-08_06
At line 199 of file rrpr.f90 (unit = 13, file = './PFILE:2014-04-08_06')
Fortran runtime error: Unformatted file structure has been corrupted

When the process stops, in my WPS directory I can see the PFILEs for each hour and the FILE:2014-04-08_00, which corresponds to the previous hour I am working with. What I did trying to figure out the trouble is:

.- I checked my namelist.wps in order to find "problematic" symbols such as #

.- I modified the star_date and end_date in my namelist.wps and I have detected that the trouble take place with files corresponding to the hour 06:00:00, whatever the date is. To make this conclusion I tried:
1.- I executed ./ungrid.exe for a different date, with the corresponding GFS files. Then, I got the same trouble with the PFILE:2017-12-25_06, again
at time 06:00:00
2.- I executed ./ungrib.exe with start_date = 2014-04-08_12:00:00 and end_date = 2014-04-09_00:00:00, avoiding time 06:00:00. In this case it worked

.- I opened the subroutine rrpr.f90 inside the directory WPS/ungrib, but I did not identify what could be the trouble

I will be really glad if someone suggest me any possible solution to this trouble.
Thanks in advance.

Below is my namelist.wps:

&share
wrf_core = 'ARW',
max_dom = 3,
start_date = '2014-04-08_00:00:00','2014-04-08_00:00:00','2014-04-08_00:00:00',
end_date = '2014-04-09_00:00:00','2014-04-09_00:00:00','2014-04-09_00:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
opt_output_from_geogrid_path = '/clima1/wrf/wrf_joaquin/test0/salidas_wps',
debug_level = 1000
/

&geogrid
parent_id = 1, 1, 2,
parent_grid_ratio = 1, 3, 3,
i_parent_start = 1, 25, 58,
j_parent_start = 1, 25, 58,
e_we = 100,151,100,
e_sn = 100,151,100,
geog_data_res = '2m','2m','2m',
dx = 27000,
dy = 27000,
map_proj = 'lambert',
ref_lat = 38.90,
ref_lon = -6.95,
truelat1 = 38.90,
truelat2 = 38.90,
stand_lon = -6.95,
geog_data_path = '/clima1/wrf/Geog/',
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE',
io_form_metgrid = 2,
/

&mod_levs
press_pa = 201300 , 200100 , 100000 ,
95000 , 90000 ,
85000 , 80000 ,
75000 , 70000 ,
65000 , 60000 ,
55000 , 50000 ,
45000 , 40000 ,
35000 , 30000 ,
25000 , 20000 ,
15000 , 10000 ,
5000 , 1000 ,
/
 
Hi,
Can you tell me what version of WPS you are using, and what type of input data? Can you attach the following files:
- ungrib.log
- Vtable you are using (make sure to attach the actual Vtable from ungrib/Variable_Tables/, and not just the link)
- if possible, can you also attach 1 of your input data files?

FYI: To attach files, locate the blue "Options" tab below the text editing window. You'll see a tab next to that. If you click on it, it will allow you to upload attachments. This forum platform (phpBB) requires that we declare every type of attachment we will allow (e.g., .txt, .namelist, .F, etc.), so if you have a suffix that it won't allow, just add a .txt to the end of it, and then it should work. And then let me know the suffix so that I can add it to the list for future uploads. Thanks!
 
Hello,

thanks for your soon answer. Let me answer your questions about the exercise I am working with:

I am working with WRF-Solar which include a version 3.9 of WRF and with GFS data for the Lateral-Boudary Conditions.

Today I have just tried again two different exercises and I have obtained again the same message error:

At line 199 of file rrpr.f90 (unit = 13, file = './PFILE:2017-12-25_06')
Fortran runtime error: Unformatted file structure has been corrupted

Although today I got the error for different times with each simulation (one at 12:00:00 and the other at 06.00:00)

I attach you the following files:

.- the Vtable I are using as “Vtable.txt”
.- input data files for test1: guada_wrf_test1.zip (namelist.wps, GFS data,ungrib.log, image of the execution process)
.- input data files for test2: guada_wrf_test2.zip (namelist.wps, GFS data,ungrib.log, image of the execution process)

I hope this would be useful for you for helping me to figure out my troubles with WRF.
Thank you very much!
 

Attachments

  • guada_wrf_test1.zip
    222.5 MB · Views: 60
  • Vtable.txt
    3.8 KB · Views: 56
I add to this second message the files for the second simulation.
Thanks in advance!!
 

Attachments

  • guada_wrf_test2.zip
    233.5 MB · Views: 47
Thank you for sending those. I ran a test with your namelist, Vtable, and GFS files and it ran without any problems.

Since you are getting the same error for both test 1 and test 2, let's just work with test 1 for now. Can you re-run ungrib, but please set debug_level = 0 in your namelist. Turning this on doesn't usually give any helpful information, and consequentially just adds a lot of junk to the log file (especially when setting it to a high number), making it more difficult to read. After that, can you send your new ungrib log, along with the files /ungrib/src/rrpr.f90 and /ungrib/src/rrpr.F? Thanks!
 
Hi!

I attach the ugrib.log when the parameter debug_level is set to 0. Additionally, I sent you the soubroutine rrpr.F and the rrpr.f90 created after the compilation.

I made an extra test regarding to the files FILE* ang PFILE* created during the process. As you can see the ungrib.log stop at time 18:00:00 but the message error say:

“At lie 199 of file rrpr.f90 (unit = 13, file = ‘PFILE:2014-04-08_12’)
Fortran rutime error: Unformatted file structure has bee corrupted “

I have used the program rd_intermediate.exe (in WPS/util/) trying to open the PFILE* and FILE* created from the process. The result is: I can see the content of the PFILE* at -08_00, -08_06 and -08_12 (the times before the ungrib.log stops) but not of the PFILE at -08_18, -09_00 and any of the FILE. I also attach a .zip with these PFILEs and FILESs.
 

Attachments

  • rrpr.f90
    34.4 KB · Views: 52
  • rrpr.F
    34.4 KB · Views: 51
  • ungrib.log
    28 KB · Views: 49
  • pfiles_files.zip
    109.2 MB · Views: 45
Hi,
There are several differences between your rrpr.F file and the default file that comes with the standard WPSV3.9 code. I did a test with your file and I also get errors, but when running with the default version of the file, everything runs to completion. I'm going to attach the default version of the code. Save your rrpr.F file as something else (so as to not overwrite it), and then place this attached version in your WPS/ungrib/src/ directory. Go back to the WPS/ directory and recompile ungrib (./compile ungrib >& log.compile.ungrib) and then try to run it again to see if you're able to get past the errors. If so, then you may want to take a look at the differences in the 2 files to determine if any differing components are specific to the WRF-Solar code, and whether you actually need any of those differences. Unfortunately WRF-Solar was developed by an outside group, so we don't have much experience with the specifics of it within our group, but if need be, I can try to contact the developer if you still have any questions.
 

Attachments

  • rrpr.F
    46.6 KB · Views: 64
Top