Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) WRF SCM Compiling error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

MartinHagman

New member
Hi!

I have run WRF SCM without forcing for many years, version 3.9.1, and have worked together with Wayne Angevine at NOAA in Boulder. I have had some problems with this model crashing, when forced, and I have started another topic about that a week ago. To compare and try a newer version, I downloaded WRF 4.3.3 and configured it on a cluster here in Sweden. It is the same cluster where I run 3.9.1. It is no problem to construct configure.wrf and the compiling process seems to work the whole way, because log.compile is as big as it used to be. But.....in the end I get the message "problem to build executeables".

I have attached configure.wrf and log.compile here.

One thing that is strange is that now I have to choose "nesting option=0" because if I choose "nesting option=1" the compiling process crashes immediately. When I compiled version 3.9.1 it worked also with nesting option=1. Has this changed lately?

Anyway, my question is why the executeables don't build with nesting option=0 and the configure option=18, as can be seen in my attached files. I have tried to understand by looking at error messages in log.compile, but I can't figure it out.

THANKS!!

//Martin Hagman, Stockholm, Sweden
 

Attachments

  • log.compile
    847.2 KB · Views: 24
  • configure.wrf
    21.2 KB · Views: 25
Hi Martin,
There are no specific error messages in your compile log (with the exception of the final message). Can you recompile using the ">&" syntax to ensure the standard error and output are included in the log file? Make sure to clean the code first.

./clean -a
./configure
./compile em_scm_xy >& log.compile

Regarding nesting, since earlier versions the build has been updated to ensure that 2D and 1D idealized cases are not built with a nesting option, as it's unreasonable to try to do nesting with these simulations.
 
Hi Kelly!

Thanks for your answer! :)

I always write like this "./compile em_scm_xy >& log.compile"

Does "log.compile" look like I did not write like that...?

Anyway, I will do it one more time and come back to you with my new output.

//Martin
 
Martin,
The fact that the end of the log file shows that you had errors, but there are no errors listed in the file indicates that you didn't compile with ">&" this time. Perhaps it was a mis-type. Hopefully your new log will show some errors. Thanks for trying again!
 
Hi Kelly!

I have compiled one more time and I have also attached a screen shot of how I wrote in my terminal window.

Best,

Martin Hagman
 

Attachments

  • log.compile
    847.2 KB · Views: 23
  • Skärmavbild 2022-02-16 kl. 10.21.33.png
    Skärmavbild 2022-02-16 kl. 10.21.33.png
    71.1 KB · Views: 333
Martin,
Thanks for trying that again. In combing through your compile log, I found the following:
Code:
ld: cannot find -lhdf5_hl
ld: cannot find -lhdf5
make[1]: [em_wrf] Fel 1 (ignoreras)
I believe, perhaps, that "Fel" in Swedish is the same as "Error" in English? If that's the case, then it looks like the issue is with a couple of the hdf5 libraries. Beginning with one of the more recent versions of WRF, it automatically builds with NetCDF-4 capabilities, which require HDF5 libraries. If you do not wish to build with those (and it's not necessary to do so), you can set
Code:
export NETCDF_classic=1
prior to configuring. Otherwise, you will need to check to make sure you have the missing libraries, and make sure your path is pointing to the correct location.
 
Thank you Kelly!

With your help, I solved the problem. I needed to load a PHDF5 module and set a PHDF5 environment variable. This was not necessary when I compiled WRF 3.9.1.1.

Again,

THANKS! :)

Best,

Martin
 
Top