Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(Solved) WRF executables successfully built but error occur when configuring WPS

f930139

New member
Hi, I am Grace, new to WRF and MPAS. I need WRF-WPS to build initial data for MPAS model.
After compling WRF, I run the command ./configure under WPS directory, but get the following error:

Error: The $WRF_DIR environment variable was set, but the WRF code at
/work/u4648924/wrf-model/WRF/main doesn't appear to have been successfully compiled

I saw another post here (Error: WPS code does not succesfully compiled ) but the solution does not really help...

The compile_wrf.log is as attached.
All suggestions are welcome!
 

Attachments

  • compile_wrf.log
    62 KB · Views: 9
Last edited:
I figured out the problem.
The $WRF_DIR should be set at where configure is located, instead of the .exe files.

WPS successfully compiled after moving WPS out of WRF directory. In my case, WPS directory is located at /work/u4648924/wrf-model/WPS, and WRF directory is located at /work/u4648924/wrf-model/WRF
 
Last edited:
Top