Unclosed moisture budget in MYNN scheme

MatzeG

New member
Hi,
While running some idealized simulations with WRF version 4.1, I noticed severe problems in the moisture budget when using the MYNN scheme.
For a systematic test, I used the single-column model test case (em_scm_xy, no code modifications) with the attached input sounding and various PBL scheme settings (see attached namelist files).
Then I compared the accumulated moisture sources minus sinks (integral of QFX - RAINNC, only liquid precipitation occurred) to the change in total water content of the atmosphere, delta Qt:
qt.png
The resulting moisture budget terms are displayed here:
View attachment waterbudget_qbud_wet_scm.pdf

For the LES (high-resolution without PBL scheme), MYJ and YSU schemes the two curves (red and violet) are reasonably close to each other, whereas for the two MYNN scheme variants they are not.
With the MYNN2 scheme, the atmosphere keeps losing more water (large negative delta Qt) than expected from the sum of the surface moisture flux and precipitation (QFX-RAINNC).
With the MYNN3 scheme instead, the atmosphere does not lose enough water given the large amount of precipitation.

Playing around with the namelist options bl_mynn_edmf, icloud_bl, scalar_pblmix, and bl_mynn_mixscalars did not change the curves significantly.
Dry air mass is conserved in all simulations, as I checked.

What is the problem here? I thought water mass should be conserved in WRF. But for the MYNN scheme, the budget is really bad!

Thanks for helping!

Matthias
 

Attachments

  • namelist.MYNN3.input
    4.8 KB · Views: 45
  • namelist.MYNN2.input
    4.8 KB · Views: 57
  • namelist.MYJ.input
    4.9 KB · Views: 47
  • namelist.YSU.input
    4.8 KB · Views: 51
  • namelist.LES.input
    6.4 KB · Views: 55
  • input_sounding.txt
    36.4 KB · Views: 53

kwerner

Administrator
Staff member
Hi Matthias,
I would like to apologize for the delay in response. We have tried to reach out to the developer for MYNN, but have not received a response yet. We will let you know as soon as we do.
 

joeolson42

New member
Are you using a microphysics scheme without an ice specie?
If so, could you please retry your experiment with a more complicated scheme?

I ask these questions because I'm guessing that this is some "strange" configuration that we don't test. We have never seen this drastic of a moisture budget problem in idealized of real cases, even going out 5+ day forecasts.

I may have a fix for simple microphysics schemes if this really is the problem.

Thanks in advance,
-joe
 

MatzeG

New member
Thanks for the replies. As can be seen in the namelist file I use mp_physics=2, which has ice processes included.
 

joeolson42

New member
Hi Matthias,

I saw your email, but I've been slammed with deadlines/conferences/workshops/proposals/paper reviews/etc. I don't mean to ignore this problem. In fact, I hope to attack it soon. Maybe we can iterate directly through email and just post a fix to this forum when we find one. I have a few ideas about where this problem may be coming from. It may take some coordinated testing or perhaps you can share your specific model setup(?).

-joe
 
Top