Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF 4.3.3 near immediate segmentation fault (sometimes?)


New member
Hi all,

I'm running WRF4.3.3 over a domain with Colorado using ERA5 as boundary conditions. Right now I'm just running a single domain with a 9km grid spacing and experiencing an almost immediate segmentation fault when calling wrf.exe. I'm able to run WPS and real.exe without an issue. My first thought was the my domain boundary may have been a little to close to some topography, but after expanding the domain I'm still getting the seg fault... What is strange is that I have had WRF run successfully on occasion over this domain, but I can't seem to make any rhyme or reason as to why... I've tried recompiling in debug mode, but that didn't seem to provide much additional information, I'm somewhat at a loss as to what to try next.

I don't think there's much useful information in my rsl files, but I've attached them here anyway. My namelist and some met files are also attached. Any suggestions would be greatly appreciated!



  • met_em_files.tar
    110 KB · Views: 1
  • rsl.tar
    120 KB · Views: 4
  • namelist.input.txt
    5.7 KB · Views: 5
The met_em* files you attached are only links to your actual met_em* files. Can you package up the actual files (and since it stops immediately, I only need the first 1 or 2 time periods) and try attaching those, instead? If you're unable to attach due to large file size, see the home page of this forum for instructions on uploading large files. Can you also attach your namelist.wps file, just so I can take a look at that too? Thanks!
ooops! I must not have been paying attention - sorry! Here's my namelist from WPS, but it seems like I don't have permission to upload files to Nextcloud. The link on the homepage goes to the download folder and there doesn't appear to an option for uploading... dragging and dropping files results in a permission error.

Thank you for your help, I really appreciate it!


  • namelist.wps.txt
    1.7 KB · Views: 1
Hi kwerner, sorry for the delay, I somehow missed your update! I just uploaded my met files tp nextcloud and it looks like everything worked! They are named tpartrid_met_files.tar.

I'm very curious to see if you run into the same segmentation fault I'm seeing...

Thanks for your continued help on this!
Hi, Thanks so much for getting those to me, and sorry for all the Nextcloud confusion. Just an FYI - I deleted all the back/forth messages between us regarding that issue since it's not related to the WRF issue (it just helps readability for anyone looking at this post in the future).

I ran a test to mimic your simulation, using the met_em* files you sent, along with the namelist.input file you previously sent, with WRF version 4.3.3, and using 16 processors, and it ran to completion without any issues. This leads me to believe there is either something wrong with your compiled version of WRF (did you modify the code in any way?), or that there is an issue with your environment - for e.g., either you don't have enough disk space or you don't have permissions to write to the directory where you're trying to write files. If you didn't modify the code in any way, unfortunately you may need to check with a systems administrator at your institution to see if they can help with the issue. Let us know if you figure it out!
Thanks for running those met files. At least it helps narrow it down a little. I haven't made any changes to source code, but I think the operating system on our cluster was updated a few months ago and I know WRF4.3.3 worked prior to those updates... I'll do some more digging.

Thanks again!