Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF-CHEM 4.4.2 do not produce dust in exercise 1

Hello I have a slight problem with WRF-CHEM.
I'm starting simulations using WRF-CHEM. I have compiled version 4.4.2 and I do not have DUST, CLAYFRAC and SANDFRAC in wrfinput in exercise one from tutorial (https://ruc.noaa.gov/wrf/wrf-chem/tutorialexercises/tutorialexercises001.html). I have them in met_em's but after vertical interpolation using real.exe they are lost. Only EROD remains.

I have corrected namelist.input which are on Tutorial Exercises For WRF-Chem Version 4.0 because they are some mistakes generating fatal errors as well as some not fatal conected to physics schemes but I still do not have DUST neither in wrfinput nor in wrfout's.

I have attached my namelist.input.

I would be grateful for any clues.
 

Attachments

  • namelist.input
    7.5 KB · Views: 10
Hi karolprzezdziecki !
In your namelist you need to remove chem_opt = 401, from the physics part (&physics). May be this is the cause of the problem.
Otherwise, I share with you the namelists I used to run this exercise two years ago.
Rachid
 

Attachments

  • namelist.wps
    1.6 KB · Views: 24
  • namelist.input
    6.9 KB · Views: 28
Thanks you both for sharing.
I'm also having this error.
geogrid runs normaly and generate HGT_M, LANDMASK, EROD, CLAYFRAC, SANDFRAC.
But when it goes to WRF the same problem appears.
I changed chem_op to 1 and dust_opt to 3 and/or 1. but the problem remains.
real.exe runs, but not generate DUST, CLAYFRAC and SANDFRAC.
The impression i have is that chemistry is not activated so there's no aerosols output although the wrchem compiled completely well.
Any insite, please help ;-)
 
Karolprzezdziecki and Edi_duarte,
I used to have the same problem in my early beginnings with WRF-Chem.
Make sure that while compiling WRF, you have the following environmental variables setup:
  • EM_CORE=1
  • WRF_CHEM=1
I got the impression that this is not mentioned in the compilation manual of WRF, but I have found this issue in WRF-ChemFAQ:
In my case, this solved the problem of missing DUST/CLAY/SAND in wrfinput.
Good luck.
 
Hi everybody!
When you use chem_opt = 401, and dust_opt = 1: These choices turn on the 5-bin dust only "chemistry" and restrict the emissions to the five (5) dust arrays.

I rerun the exercise (with different dates and domains) using the new version (4.4.2) of WRF-chem, and when I checked the wrfinput file I found empty values for DUST_1 (the array exist but values are 0--> this will be computed by wrf.exe), but EROD, CLAYFRAC and SANDFRAC are not empty and have good values.

For wrfout files (wrf.exe outputs) DUST_1 arrays are not empty. So I think chem_opt = 401, and dust_opt = 1 is working.
May be you forget to set WRF_CHEM=1 when installing wrfchem as suggested.

In the following link you will find output files for the exercise:
 
Last edited:
Karolprzezdziecki and Edi_duarte,
I used to have the same problem in my early beginnings with WRF-Chem.
Make sure that while compiling WRF, you have the following environmental variables setup:
  • EM_CORE=1
  • WRF_CHEM=1
I got the impression that this is not mentioned in the compilation manual of WRF, but I have found this issue in WRF-ChemFAQ:
In my case, this solved the problem of missing DUST/CLAY/SAND in wrfinput.
Good luck.
Thank you it solved the problem indeed. :)
 
Karolprzezdziecki and Edi_duarte,
I used to have the same problem in my early beginnings with WRF-Chem.
Make sure that while compiling WRF, you have the following environmental variables setup:
  • EM_CORE=1
  • WRF_CHEM=1
I got the impression that this is not mentioned in the compilation manual of WRF, but I have found this issue in WRF-ChemFAQ:
In my case, this solved the problem of missing DUST/CLAY/SAND in wrfinput.
Good luck.
Hallo,
Many thanks! You were right!
Now is running!
 
Top