Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF crashes in RUC LSM with Goddard MP scheme

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I'm using V 4.1.2 with the attached namelist. WRF fails before outputting the first time step in the RUC LSM scheme, with an AVOST in VILKA error in the surface energy budget. The value for Psfc is NaN, as you can see in the attached rsl file. It looks to me like the RUC LSM is not being provided with a value for Psfc, but I could be wrong. My wrf input and bdy files can be accessed via the nextcloud site as mbaxter_input_bdy.tgz.

Please let me know if you have any ideas on how I could get past this. The input data works fine when using the WDM6 and Thompson schemes. I am working on a project that compares different microphysics schemes with everything else in the namelist held constant, and thus would like to avoid using schemes other than those that I've selected in the namelist. Running on 20 processors on a single node using the intel compilers. No modifications to the WRF code.




  • rsl_namelist.tar
    104 KB · Views: 56
Thank you for sending the necessary files for me to be able to try to run this. Unfortunately I wasn't able to repeat the problem - even when using your namelist, your wrfbdy_d01/wrfinput_d01 files, and WRFV4.1.2, compiled with Intel. I also used 20 processors. The run completes without any problems. Without being able to reproduce the problem, it's very hard for me to diagnose.

1) I first would like to ask you to try setting this in the &physics section of your namelist:
seaice_threshold = 271

and see if that helps at all.

2) If not, then I would suggest putting in some print statements to see where the NaN originates for Psfc at one of the points that is mentioned in the rsl* files. If you take a look at the end of the rsl.out.0014 file, for example, you will see:
      AVOST IN VILKA     Table index=  -2147483648
 I,J=         419         353 LU_index =           15 Psfc[hPa] = 
            NaN Tsfc =    272.3050    
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  module_sf_ruclsm.b  LINE:    6490
  Crash in surface energy budget

So this is failing around line 6481 in module_sf_ruclsm.F. If you look at that code, "pp" is the variable name for Psfc here. If you make modifications to the file, you'll need to recompile the code, but you don't need to issue a 'clean -a' or a reconfigure. As you're not making any changes to the registry, just simply recompile, and it should be faster than the original/full compile. I'm sorry I don't have more answers. Please keep us posted.

Thanks for your efforts. I tried the quick fix to the seaice threshold but to no avail. I can work on writing out from the ruc lsm code, but as you know this can be quite the process. I will let you know how it goes.

Could you possibly send me your configure.wrf file as well as which version of the intel compiler you used? I'm wondering if it is something specific to my compilation since my files worked for you but not for me. I'm running this on Michigan State's HPCC, using the option of Intel Xeon (SNB with AVX mods).


Hi Marty,
Yes, I'm attaching that configure file, which will definitely differ, as I'm running on NCAR's Cheyenne supercomputer (Linux-based OS), with Intel/icc.


  • configure.wrf
    23.1 KB · Views: 62
Hi Mbaxter..

Did you find any solution ??
i am also getting the same error.
can you please share the solution for this error.

Thanks in Advance
Hello Sunil,

Unfortunately I did not pursue this further. It seems to be very challenging since wrfhelp did not encounter the same error with the same configuration. If I do pursue it eventually and figure something out I will post here. Feel free to do the same if you solve it!

Hi Mbaxter,

Did you find any solution ??
I am also getting the same error.
can you please share the solution for this error.

Best regards!

yours sincerely,
If you are getting this same error, we recommend putting in some debugging print statements. See the post from me on Aug 6, 2019. If you're not already doing so, I would also recommend trying the latest version of WRF (V4.2.1) to see if that helps.