Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF error: horizontal interp error - island

Zoo

New member
Dear all,
I run a real case with WRFV3.3, but the integration can not continue after ./wrf.exe, there is no error before the last step.
I checked every rsl.error*, find similar error with "[a3407n09:30775:0:30775] Caught signal 11 (Segmentation fault: address not mapped to object at address 0x7fff071fe000)", and the largest one said "horizontal interp error - island, using average 304.8616" (details can be found in the file)

Can you tell me whether it comes from the fault of my namelist or somewhere else?


I would appreciate it if you would take the time out of your busy schedule to check out my problem and give suggestions!
Best regards,
Zoo
 

Attachments

  • namelist.input
    4.3 KB · Views: 4
  • rsl.error.0003.txt
    5.4 KB · Views: 1
  • rsl.error.0095.txt
    8.4 KB · Views: 1
Hi,
If I search for CFL errors in your rsl.* files, I am seeing some:
Code:
rsl.error.0095.txt: d01 2006-01-19_06:00:00          380  points exceeded cfl=2 in domain d01 at ti
rsl.error.0095.txt: rt_cfl,w,d(eta)=   262.3822      -846.9896      2.7197244E-02
rsl.error.0095.txt: d02 2006-01-19_06:00:00           58  points exceeded cfl=2 in domain d02 at ti
rsl.error.0095.txt: rt_cfl,w,d(eta)=   8.656702      -68.26199      1.9999981E-02

This indicates the model has become unstable, typically due to complex terrain. The first solution for this is to decrease your time_step, but you are already using a very small time_step, so I would advise to take a look at this FAQ that discusses some other options you could try.

Unfortunately the version of WRF you are using is very old and we don't support that version anymore. It may be worth upgrading to one of the latest versions to see if you still experience the same problem.
 
Thank you so much for your advice. For some special research, I want to test the results from WRFV3. After I reset the namelist.input, the fault of CLF disappeared, but the horizontal interp error still exists. Could you help me to deal with it?

The new namelist and rsl.error attached here:
 

Attachments

  • namelist.input
    5.4 KB · Views: 2
  • rsl.error.0064.txt
    5.1 KB · Views: 3
Thanks for your reply. I checked it carefully and found it's not a vortex-following case. I try to change the start and end date of this TWP-ICE, but it doesn't help. The same error still exists.
 
Hi,
Since we don't support the older code, just as a test, can you try this with the newest release of the WRF code to see if you still get the same error? If you do, then we will know it's not version-dependent, and I can try to help with it.
 
Top