Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf.exe crashed after sometime with out any error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

sunil_babu

New member
Hey guys....
I am running wrf 4.1.4 version for the year 2015 by month wise.
the model was successful for all the months except April, May, and December.
everything(input data, parameterizations,...) is the same for all the months except date change.
But don't know why, the model is giving segmentation fault error after running for some time(for Dec month 9hrs, April-26hrs, May-20hrs).
I checked for the memory, there is no issue. After the model getting crashed I ran the model for the month of September, the simulation was completed without any error.
I freshly downloaded gfs input data & SSTdata again and tried but still, the model is getting crashed exactly at the same point as the previous run.

What can it be? Any ideas?

Thanks in advance
 

Attachments

  • error 28122020.png
    error 28122020.png
    183.1 KB · Views: 485
  • namelist.input
    3.3 KB · Views: 30
  • rsl.error.0001.txt
    99.8 KB · Views: 24
  • rsl.error.0002.txt
    94.3 KB · Views: 23
  • rsl.error.0003.txt
    94.3 KB · Views: 23
  • rsl.error.0004.txt
    94.3 KB · Views: 25
  • rsl.error.0006.txt
    94.3 KB · Views: 26
  • rsl.error.0007.txt
    94.3 KB · Views: 24
  • rsl.error0000.txt
    3 MB · Views: 24
  • rsl.error0005.txt
    94.8 KB · Views: 29
rest of the rsl files and system specifications are attached below.
 

Attachments

  • rsl.error.0008.txt
    94.3 KB · Views: 30
  • rsl.error.0009.txt
    94.3 KB · Views: 22
  • rsl.error.0010.txt
    94.3 KB · Views: 27
  • rsl.error.0011.txt
    94.3 KB · Views: 28
  • rsl.error.0012.txt
    94.3 KB · Views: 28
  • rsl.error.0013.txt
    94.3 KB · Views: 23
  • system specifications.txt
    1.6 KB · Views: 29
Please take a look at your wrfout files right before the model crashed and see whether you can find something unusual, NAN or unreasonable pattern of certain variables.
If all looks normal, you may save wrfrst file a few time steps before the model crashed, then restart and save wrfout at every time step. Hopefully in this way you can find some hints when and where the model went wrong first.
Another option is, you can compile WRF with ./configure -D, then rerun the failed case. This will give you information where the problem first popped up.
 
Top