Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF writing output at random intervals

george_victor

New member
Hi! Recently I was making a simulation, which ended with a CFL error. So I restarted the simulation with restart files and some modification in parameterizations. However when the new simulation started, it is writing outputs every second, although my setting says "history_interval = 30, 5,". Multiple attempts in different folders had same result. There were no errors that popped up. Adding to this, please note that I'm using adaptive time stepping.

Why is this happening? What is the solution?

Although the intial part of simualation (before the restart) gave outputs which are good/as expected, I'm not even sure if the outputs are correct or wrong for the later part (after restart). The output files from restart simulation are huge.

Here are few lines from the rsl.error.0000 file:
(entire file is attached, the simulation was forced stopped after seeing outputs like this)

Timing for main (dt= 0.43): time 2015-10-12_02:00:00 on domain 2: 0.54455 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:00 on domain 2: 0.52047 elapsed seconds
Timing for main (dt= 0.85): time 2015-10-12_02:00:00 on domain 1: 7.77391 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:01 on domain 2: 0.55059 elapsed seconds
Timing for Writing wrfout_d02_2015-10-12_02:00:01 for domain 2: 1.17589 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:01 on domain 2: 1.69602 elapsed seconds
Timing for main (dt= 0.85): time 2015-10-12_02:00:01 on domain 1: 6.02152 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:02 on domain 2: 0.54447 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:02 on domain 2: 0.52012 elapsed seconds
Timing for main (dt= 0.85): time 2015-10-12_02:00:02 on domain 1: 4.83822 elapsed seconds
Timing for Writing wrfout_d02_2015-10-12_02:00:02 for domain 2: 0.79049 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:02 on domain 2: 1.31069 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:03 on domain 2: 0.52017 elapsed seconds
Timing for main (dt= 0.85): time 2015-10-12_02:00:03 on domain 1: 5.61148 elapsed seconds
Timing for Writing wrfout_d02_2015-10-12_02:00:03 for domain 2: 0.77503 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:03 on domain 2: 1.29556 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:04 on domain 2: 0.55311 elapsed seconds
Timing for main (dt= 0.85): time 2015-10-12_02:00:04 on domain 1: 5.61365 elapsed seconds
Timing for main (dt= 0.43): time 2015-10-12_02:00:04 on domain 2: 0.54220 elapsed seconds
Timing for Writing wrfout_d02_2015-10-12_02:00:04 for domain 2: 0.75696 elapsed seconds

Here is the namelist: (file attached)

&time_control
start_year = 2015, 2015, 2015, 2015,
start_month = 10, 10, 10, 10,
start_day = 12, 12, 11, 11,
start_hour = 02, 02, 00, 00,
start_minute = 00, 00,
end_year = 2015, 2015, 2015, 2015,
end_month = 10, 10, 10, 10,
end_day = 12, 12, 12, 12,
end_hour = 18, 18, 18, 18,
interval_seconds = 10800
input_from_file = .true.,.true.,.true.,.true.,
history_interval = 30, 5, 120, 15,
frames_per_outfile = 1000, 1000, 1000, 1000,
restart = .true.,
restart_interval = 30,
io_form_history = 2
io_form_restart = 2
io_form_input = 2
io_form_boundary = 2
io_form_auxinput2 = 2
/

&domains
use_adaptive_time_step = .true.,
step_to_output_time = .true.,
target_cfl = 1.2, 1.2, 1.2,
target_hcfl = 0.84, 0.84, 0.84,
max_step_increase_pct = 4, 51, 51,
starting_time_step = 65, 40
starting_time_step_den = 100, 100
max_time_step = 85, 60
max_time_step_den = 100, 100
min_time_step = 5, 5
min_time_step_den = 100, 100
adaptation_domain = 1,
time_step = 0,
time_step_fract_num = 64,
time_step_fract_den = 100,
max_dom = 2,
e_we = 436, 280,
e_sn = 166, 82,
e_vert = 54, 54, 54, 54,
p_top_requested = 5000,
num_metgrid_levels = 38,
num_metgrid_soil_levels = 4,
dx = 240, 80,
dy = 240, 80,
grid_id = 1, 2, 3, 4,
parent_id = 1, 1, 2, 3,
i_parent_start = 1, 172,
j_parent_start = 1, 70,
parent_grid_ratio = 1, 3,
parent_time_step_ratio = 1, 11,
feedback = 0,
smooth_option = 0
eta_levels = 1.00000, 0.99970, 0.99940, 0.99910, 0.99880
0.99830, 0.99795, 0.99760, 0.99700, 0.99640
0.99580, 0.99520, 0.99445, 0.99370, 0.99295
0.99195, 0.99095, 0.98995, 0.98870, 0.98745
0.98620, 0.98495, 0.98295, 0.98095, 0.97895
0.97695, 0.97495, 0.97120, 0.96745, 0.96370
0.95995, 0.95495, 0.94995, 0.93995, 0.92995
0.91995, 0.90995, 0.89995, 0.87495, 0.84995
0.82495, 0.79995, 0.74995, 0.69995, 0.64995
0.59995, 0.54995, 0.49995, 0.42495, 0.34995
0.27495, 0.19995, 0.12495, 0.00000,
/

&physics
physics_suite = 'CONUS'
mp_physics = -1, -1, -1, -1,
cu_physics = 0, 0, 0, 0,
ra_lw_physics = 4, 4, 4, 4,
ra_sw_physics = 4, 4, 4, 4,
bl_pbl_physics = 0, 0,
sf_sfclay_physics = 2, 2, 2, 2,
sf_surface_physics = 4, 4, 4, 4,
radt = 0.3, 0.1,
bldt = 0, 0, 0, 0,
cudt = 5, 5, 5, 5,
icloud = 1,
num_land_cat = 21,
sf_urban_physics = 0, 0, 0, 0,
num_soil_layers = 4,
surface_input_source = 1,
fractional_seaice = 1,
seaice_thickness_opt = 0,
seaice_thickness_default = 3.0,
seaice_albedo_opt = 1,
seaice_snowdepth_opt = 0,
seaice_snowdepth_min = 0,
seaice_snowdepth_max = 3,
tice2tsk_if2cold = .true.,
isfflx = 1,
ifsnow = 0,
/

&fdda
/

&dynamics
hybrid_opt = 2,
w_damping = 1,
epssm = 0.85,
diff_opt = 2, 2,
km_opt = 2, 2,
diff_6th_opt = 0, 0, 0, 0,
diff_6th_factor = 0.12, 0.12, 0.12, 0.12,
mix_isotropic = 1, 1, 0, 1,
base_temp = 290.
damp_opt = 3,
zdamp = 5000., 5000., 5000., 5000.,
dampcoef = 0.2, 0.2, 0.2, 0.2,
non_hydrostatic = .true., .true., .true.,.true.,
moist_adv_opt = 1, 1, 1, 1,
scalar_adv_opt = 1, 1, 1, 1,
gwd_opt = 1,
/

&bdy_control
spec_bdy_width = 10,
specified = .true.
spec_zone = 1,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,

/
 

Attachments

  • rsl.error.0000
    49.2 KB · Views: 1
  • namelist.input
    5.8 KB · Views: 0
Hi! Apparently the issue seem to be resolved (simulation is on-going and so far it isn't writing outputs as described in the error), by adding "override_restart_timers = .true.," under the "&time_control" section in the namelist.input file. The solution was found under the discussion of a similar query. However, I'd still like to know why this happen?
 
You are right that the option below can solve your problem.

override_restart_timers = .true.

This is because when WRF runs in restart mode, the restart_interval specified in previous run will remain valid. If this option in the restart run is different to that in the previous run, somehow the model will get confused.

WIth the option override_restart_timers = true, the previous value of restart_interval will be replaced by the current one and thus avoid the confusion.
 
Top