WRF4.4 compilation failed on vortex following nesting

SunJianping

New member
I'm trying to build WRF 4.4 and have followed the instructions on https://www2.mmm.ucar.edu/wrf/OnLineTutorial/compilation_tutorial.php. All tests were good and the compilation worked well with basic nesting, bu terrors occured when I tried vortex following.
Here are my configure and log files of basic and vortex following nesting. Any help would be greatly appreciated!
 

Attachments

  • basic_configure.wrf
    23.4 KB · Views: 2
  • basic_log.compile
    733.3 KB · Views: 1
  • vortexfollwing_configure.wrf
    23.5 KB · Views: 1
  • vortexfollwing_log.compile
    854.1 KB · Views: 1

kwerner

Administrator
Staff member
Hi,
When you compiled this for the vortex following option, did you download the source code again and start from scratch? If not, try that, and make sure you are grabbing either the "v4.4.tar.gz" or "v4.4.zip" version of the source code from the GitHub release. When compiling, issue the following so that it only compiles on a single processor (this helps to ensure the first errors shown in the log file are the ones causing the issue).
./compile em_real -j 1 >& log.compile

After that, send me the new configure.wrf and compile log. Thanks!
 

kwerner

Administrator
Staff member
Hi,
I have a temporary fix for you to try. We will talk to our software engineers to see if we can figure out a long-term solution, but for now, this one should suffice as long as you have gcc installed. If so, please try the following.

./clean -a
./configure
Then edit the configure.wrf file. Look for the following two lines and change them from "icc" to "gcc."
Code:
SCC             =       gcc
CCOMP           =       gcc
and then look for this line and change "-ip" to "-c"
Code:
CFLAGS_LOCAL    =       -w -O3 -c -DRPC_TYPES=1 #-xHost -fp-model fast=2 -no-prec-div -no-prec-sqrt -ftz -no-multibyte-chars # -DRSL0_ONLY
Save the configure.wrf file and then try to compile again. Please let me know if this works for you so that I can add an FAQ about it, if so. Thanks!
 
Top