Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRFDA ifort Error 5082: Syntax error


New member
Dear Wrf Community,

I have tried to compile WRFDA4.4 after succesfully compiling WRF/WPS4.4 with intel ifort.
I have a problem in compile that it seems related to a sintax error with module_configure.f90, module_domain.f90, module_nesting.f90 (all f90).
Part of log:
rm -f module_configure.b
/opt/intel/oneapi/mpi/latest/bin/mpif90 -f90=ifort -c -no-ip -align all -FR -convert big_endian -fno-alias -fno-fnalias -I../external/io_netcdf/ -I. -fp-model precise   -I../main -I../external/io_netcdf -I../external/io_int -I../external$
module_configure.f90(1): error #5082: Syntax error, found '/' when expecting one of: <LABEL> <END-OF-STATEMENT> ; <IDENTIFIER> TYPE MODULE ELEMENTAL IMPURE NON_RECURSIVE ...
/* Copyright (C) 1991-2017 Free Software Foundation, Inc.
module_configure.f90(16): error #5145: Invalid blank/tab
   <>.  */
module_configure.f90(20): error #5145: Invalid blank/tab
   include it implicitly at the start of every compilation.  It must
module_configure.f90(27): error #5120: Unterminated character constant
/* glibc's intent is to support the IEC 559 math functionality, real
module_configure.f90(27): error #5144: Invalid character_kind_parameter. No underscore
/* glibc's intent is to support the IEC 559 math functionality, real
module_configure.f90(28): error #5145: Invalid blank/tab
   and complex.  If the GCC (4.9 and later) predefined macros
module_configure.f90(30): error #5277: Syntax error, found ',' following statement keyword
   whether the overall intent is to support these features; otherwise,
module_configure.f90(32): error #5145: Invalid blank/tab
   define these macros by default.  */
module_configure.f90(36): error #5145: Invalid blank/tab
/* wchar_t uses Unicode 10.0.0.  Version 10.0 of the Unicode Standard is
module_configure.f90(43): error #5145: Invalid blank/tab
/* We do not support C11 <threads.h>.  */
module_configure.f90(1): catastrophic error: Could not recover from previous syntax error
compilation aborted for module_configure.f90 (code 1)
make[2]: [module_configure.o] Error 1 (ignored)
rm -f module_machine.o
sed -f ../arch/standard.sed module_machine.F > module_machine.b

I have tried also with:
FC                = $(MPI_HOME)/bin/mpif90 -f90=ifort
LD                = $(FC)
CC                = $(MPI_HOME)/bin/mpicc -cc=icc -DFSEEKO64_OK

but I have the same errors.

Any one can offer help/advice? Thanks


  • compile.log
    225.3 KB · Views: 3
  • configure.wrf
    13.2 KB · Views: 1
I tried to compile WRFDA for 3Dvar mode; in this case i think that WRFPLUS is not needed. I will check this aspect.