NCL cnFillOn strange problem

WRF model-related NCL questions/topics
Post Reply
stefano04
Posts: 5
Joined: Tue Jun 09, 2020 4:16 pm

NCL cnFillOn strange problem

Post by stefano04 » Thu Jun 11, 2020 5:39 pm

Hi,
I'm new on WRF. Today i've finished my first run and all went good. When i try to plot the data, they are displayed only if they are vector or line, but they aren't showed when they are color. I think that is a res@cnFillOn problem or some setting in .hluresfile. I attach here the ncl script, the .hluresfile and the final plot. Sorry for the stupid question but i'm new on this.
wrf_demo_plot_slp.pdf
The final plot without any color. If i set cnFillOn as false, here i see data as line
(132.38 KiB) Downloaded 13 times
.hluresfile [/b]
*wkColorMap: BlAqGrYeOrReVi200
*wkBackgroundColor: white
*wkForegroundColor: black
*FuncCode: ~
*TextFuncCode: ~
*Font : helvetica
*wkWidth: 900
*wkHeight: 900

ncl script
begin
a = addfile("wrfout_d01_2020-06-09_15:00:00","r")
slp= wrf_user_getvar(a,"slp",0) ; Sea-level-pressure(hPa)
wks= gsn_open_wks("pdf","wrf_demo_plot_slp")
res = True
res@cnFillOn = True
contour = wrf_contour(a,wks,slp,res)
plot = wrf_map_overlays(a,wks,contour,False,False)
end

stefano04
Posts: 5
Joined: Tue Jun 09, 2020 4:16 pm

Re: NCL cnFillOn strange problem

Post by stefano04 » Fri Jun 12, 2020 5:19 pm

I've risolved this problem but i have another question: how can i put on the plot the state and province border? Thank you very much fort the patient but it's the first time for me

abjaye
Posts: 55
Joined: Fri Jun 08, 2018 2:37 am

Re: NCL cnFillOn strange problem

Post by abjaye » Fri Jun 12, 2020 8:42 pm

This example page has many examples of how to plot borders:

https://www.ncl.ucar.edu/Applications/mapoutlines.shtml
NCAR/MMM

Post Reply

Return to “NCL”