refl10cm_1km_max Issue

Questions, issues, or suggestions related to post-processing of model output.
Post Reply
weathertom
Posts: 19
Joined: Mon Jun 24, 2019 10:22 am

refl10cm_1km_max Issue

Post by weathertom » Thu Jul 18, 2019 4:51 pm

When viewing output for the refl10cm_1km_max variable it appears to be identical to refl10cm_1km. I'm wondering if this is an error, or if this is the maximum over one internal model time step rather than model output times as the documentation implies (the time step in my case is just 18 seconds, whereas my output times are 1 hour). Since this isn't created in one of the diagnostic schemes (like the updraft_helicity_max) I'm wondering if that may be the case and it looks identical to refl10cm_1km, but is simply a max over 18 seconds rather than an hour and really wouldn't appear much different at all. If that's the case, I can look into writing a diagnostic for it, but I wanted to make sure I wasn't confused.

mgduda
Posts: 362
Joined: Mon Feb 26, 2018 7:35 pm

Re: refl10cm_1km_max Issue

Post by mgduda » Thu Jul 18, 2019 5:00 pm

This does sound like an issue with the calculation of refl10cm_1km_max. As you noted, this field should be the maximum of the refl10cm_1km field between output times (and not, e.g., over a timestep). Taking a brief look through the code for handling refl10cm_1km_max, I'm not sure this field would be correct if it were output in a stream other than the "diagnostics" stream. Are you by chance writing refl10cm_1km_max to a new output stream that you've defined in the streams.atmosphere file?
NCAR/MMM

Post Reply

Return to “Post-processing”