(RESOLVED) I cannot compile metgrid.exe (WPS-4.3)

All topics related to compiling the WPS, including library installation and environment set-up
Post Reply
GervyWRF
Posts: 4
Joined: Wed Jun 02, 2021 4:33 am

(RESOLVED) I cannot compile metgrid.exe (WPS-4.3)

Post by GervyWRF » Wed Jun 02, 2021 6:22 am

Hi, using Intel ifort/icc compiler on my Linux machine, I cannot build metgrid.exe (geogrid and ungrib are ok).
It happens by configuring both smpar and dmpar.
WRF-4.3 built ok.

Thank you very much for your support.
Attachments
configure.wps
(3.3 KiB) Downloaded 5 times
compile_wps.log
(82.17 KiB) Downloaded 6 times
Last edited by GervyWRF on Thu Jun 03, 2021 9:47 am, edited 1 time in total.

kwerner
Posts: 2341
Joined: Wed Feb 14, 2018 9:21 pm

Re: I cannot compile metgrid.exe (WPS-4.3)

Post by kwerner » Wed Jun 02, 2021 11:15 pm

Hi,
The error in your compile log is very similar to the one mentioned in this post (related to netcdf and the file scan_input.F). Try to use the modified file I gave that user to see if it works for you, as well.
NCAR/MMM

GervyWRF
Posts: 4
Joined: Wed Jun 02, 2021 4:33 am

Re: I cannot compile metgrid.exe (WPS-4.3)

Post by GervyWRF » Thu Jun 03, 2021 9:46 am

It works! Thank you!

kwerner
Posts: 2341
Joined: Wed Feb 14, 2018 9:21 pm

Re: (RESOLVED) I cannot compile metgrid.exe (WPS-4.3)

Post by kwerner » Thu Jun 03, 2021 7:47 pm

Great! Thanks for letting me know.
NCAR/MMM

Post Reply

Return to “WPS Compiling/Installation”