Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

about the code of mpas_bootstrapping.F

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Dear Sir:
In the code of mpas_bootstrapping.F @ line 207~ 208:
the original code:
partial_global_graph_info % nVertices = nReadCells
partial_global_graph_info % nVerticesTotal = nCells
why not it's:
partial_global_graph_info % nVertices = nReadVertices
partial_global_graph_info % nVerticesTotal = nVertices

Why the allocation of the array about vertices in the partial graph is not set by number of vertices?
Could you please explain it for me? Thank you very much!
Li Jian
The name "nVertices" of the member of the "partial_global_graph_info" derived type is somewhat confusing: it refers not to the corner points of Voronoi cells, but rather, to the vertices (also called nodes) in a graph that describes the connectivity of the cells in the MPAS mesh. That we are building a connectivity graph of the cells of the mesh is seen on L.214 of mpas_bootstrapping.F, where the adjacency list of each vertex in the connectivity graph is set to the cellsOnCell field.

To avoid confusion, perhaps we should rename "nVertices" to something like "nNodes" in the "partial_global_graph_info" structure.