Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

CBMZ does not ingest biomass burning emissions

user1987

New member
Hello all,

I was trying to run CBMZ-MOSAIC (chem-opt=9) using biomass burning emissions. When checking the uotput the aerosol species are ingested fine but the gas species are not modified.

The ebu_* for gases are in the wrffirechemi files but concentrations do not change accordingly.

I checked the module_cbmz_addemiss and only biogenic and anthropogenic emissions are added in the module. WRF v 4.1.5

Is there a way to add BB emissions to CBMZ or a different option must be used?

Thanks,
Juan
 
Hello Jordan, I used biomass_burn_opt = 1. Yes I could modify the code, but was just curious if it was possible somehow. Thanks
 
Hi Juan,

Looking at chem/module_add_emiss_burn.F, it doesn't look like CBMZ is considered at all..so I'm actually curious how you are able to get wildfire aerosol emissions.

It looks like you will need to modify the code or switch to a RACM or MOZART-based chem_opt.

Jordan
 
Hi Jordan,

the aerosols for the selected chem option are called by the MOSAIC module ( module_mosaic_addemiss.F ) and not by the module_add_emiss_burn.F... its just a CBMZ issue I guess..

I am switching to the MOZART options in this application as I need the fire emissions.

Thank you!
 
Hello Jordan, I managed to add gases from the fires, and these seem to work well. However, the aerosols are not working well with the plumerise option. I modified the module_plumerise1.F to include CBMZ-MOSAIC but don´t know why it does not work for aerosols despite it works for gases.
I compared it to mozart-mosaic (chem_opt=201) and looks fine for CO but very different for black carbon. Do you have any idea what I am missing?

I want to use cbmz-mosaic for aerosol interactions, when I use mozart-mosaic (202) the aerosols have some issues

Thanks
 

Attachments

  • coplume.png
    coplume.png
    129.1 KB · Views: 13
  • bcplume.png
    bcplume.png
    130.3 KB · Views: 13
Hello Jordan, I managed to add gases from the fires, and these seem to work well. However, the aerosols are not working well with the plumerise option. I modified the module_plumerise1.F to include CBMZ-MOSAIC but don´t know why it does not work for aerosols despite it works for gases.
I compared it to mozart-mosaic (chem_opt=201) and looks fine for CO but very different for black carbon. Do you have any idea what I am missing?

I want to use cbmz-mosaic for aerosol interactions, when I use mozart-mosaic (202) the aerosols have some issues

Thanks
Hello! Sorry to bother you. I am trying to add fire emissions through FINN v1.5 to WRF-Chem. The chemistry scheme I use is CBMZ-MOSIAC too. However i ran into the two problems.
1. After running FINN, I got hourly wrffirechemi_d01_<time> file, which can not be read into wrf. I link the hourly file into wrffirechemi_d01 to make it successfully read.
2. I set
biomass_burn_opt = 1,
plumerisefire_frq = 180,
and in the rsl.error.0000, it said
FATAL CALLED FROM FILE: <stdin> LINE: 102
Fire emission scaling only supported for MOZART_KPP, MOZCART_KPP chem options
As we use the same gas-aerosol scheme, I will appreciate it very very much if you coule give me some advice or share your configuration to me.
Much thanks!!!

Wenyu
 
Hello Wenyu,

You error seems related to the scale_fire_emiss = .true., because it only works for Mozart options.
If you want to use FINN for CBMZ-MOSAIC you have to make some changes in the code to use the scaling of emissions needed. This is done in the plumerise driver, module_plumerise1.F..
If you want to add gases from FINN emissions to CBMZ you need to make changes in the code again, perhaps in module_add_emiss_burn.F or module_cbmz_addemiss.F
I am still working on the changes when I have some free time, so I don't have a complete solution yet.

Or you can switch to a MOZART-MOSAIC option that includes the scale_fire_emiss

Juan
 
Hello Wenyu,

You error seems related to the scale_fire_emiss = .true., because it only works for Mozart options.
If you want to use FINN for CBMZ-MOSAIC you have to make some changes in the code to use the scaling of emissions needed. This is done in the plumerise driver, module_plumerise1.F..
If you want to add gases from FINN emissions to CBMZ you need to make changes in the code again, perhaps in module_add_emiss_burn.F or module_cbmz_addemiss.F
I am still working on the changes when I have some free time, so I don't have a complete solution yet.

Or you can switch to a MOZART-MOSAIC option that includes the scale_fire_emiss

Juan
Hello Juan,

Thank you so much for your reply!
Before recieving your reply I have tried to turn the namelist variable 'scale_fire_emiss' to '.false'. It seemed like that the simulation could run successfully. However after checking the results and the rsl.error log files i found that the model failed reading the wrffirechemi_d01_xxx.
图片1.png
I will try to modify the code to include the scale_fire_emiss and try again.
Also i will try to read the code to find out the solution of adding gases from FINN emissions to CBMZ because it's not likely to change the mechanics since we have done some experiments based on CBMZ-MOSAIC.

Thank you again and hopefully we can keep in touch so that we can discuss this problem.

Wenyu
 
Top