Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

compile all_wrfvar WRFDA has erro


New member
I get several errors when trying to compile WRFDA, the *.exe files were not all generated by the compilation.

make[2]: Entering directory '/home/suno/Build_WRF/WRFDA/tools'
gcc -DIWORDSIZE=4 -DMAX_HISTORY=25 -DNMM_CORE=0 -c -g registry.c
registry.c: In function ‘main’:
registry.c:63:3: warning: implicit declaration of function ‘sym_forget’; did you mean ‘sym_get’? [-Wimplicit-function-declaration]
63 | sym_forget() ;
| ^~~~~~~~~~
| sym_get .........

I have tried many times, but obtained the same result.
What‘s the reason’?
I would appreciate any suggestion from you on how to solve this problem.


  • compile.out.txt
    560.2 KB · Views: 7
based on your code that you supplied it looks like the zlib was not linked properly in the ld_library_path.

gfortran  -O2 -ftree-vectorize -funroll-loops -w -ffree-form -ffree-line-length-none -fconvert=big-endian -frecord-marker=4    
-o da_rad_diags.exe da_rad_diags.o 
-L/home/suno/Build_WRF/WRFDA/external/io_netcdf -lwrfio_nf 
-L/home/suno/Build_WRF/LIBRARIES/netcdf/lib -lnetcdff -lnetcdf     
-L/home/suno/Build_WRF/LIBRARIES/hdf5/lib -lhdf5_fortran -lhdf5 -lm -lz
/usr/bin/ld: cannot find -lz

As you can see it shows -L links to hdf5 and netcdf but not zlib.