Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Compile WPS only appear ungrid.exe

lucky

New member
Hello, when I compile WPS only ungrid.exe appears, below is my log and configure file, please help me look at it and point out the problem, thank you very much!
 

Attachments

  • configure.wps
    3.3 KB · Views: 6
  • wpscompile.log
    52.4 KB · Views: 6
Looks like you are using the Intel compilers. Did you make all the changes to the configuration paths and flags as recommended by ncar?
 
Looks like you are using the Intel compilers. Did you make all the changes to the configuration paths and flags as recommended by ncar?
Yes, I use the inter compiler, and this is the setting of my environment variables.
 

Attachments

  • Environment.txt
    627 bytes · Views: 4
Looking at your variables I don't see anything that seems wrong. I personally have never used smpar serial option I always use dmpar since I plan on using multiple cores to run WRF and WPS.

I do have a tutorial on the forum about how to set up intel compilers for WRF/WPS.

Looking at your configure.wps the only thing I see is maybe changing lines 65 and 66 to either

DM_FC = mpif90 -f90=ifort -> DM_FC = ifort or DM_cc = mpiifort
DM_CC = mpicc -cc=icc -> DM_CC = icc or DM_CC = mpiicc

Let me know if this helps you.
 
I read the environment settings you sent me about the inter compiler, so I compiled WRF and WPS using dmpar, and the result was that ungrib.exe and geogrid.exe appeared, not metgrid.exe.
 

Attachments

  • wpscompile.log
    38.9 KB · Views: 0
  • Environment.txt
    910 bytes · Views: 1
  • configure.wps
    3.5 KB · Views: 1
Last edited by a moderator:
I'm very sorry, I forgot.
I read the environment settings you sent me about the inter compiler, so I compiled WRF and WPS using dmpar, and the result was that ungrib.exe and geogrid.exe appeared, not metgrid.exe.

try changing lines 73 and 74 for configure.wps to

DM_FC = mpiifort
DM_CC = mpiicc

if that doesn't work try this one



DM_FC = ifort
DM_CC = icc
 
try changing lines 73 and 74 for configure.wps to

DM_FC = mpiifort
DM_CC = mpiicc

if that doesn't work try this one



DM_FC = ifort
DM_CC = icc
Hi, hello, I tried to modify the configure.wps file as you said, I tried many times, but the result is still not right, metgrib.exe or not, the following is my environment configuration and other files.
 

Attachments

  • configure.wps
    3.5 KB · Views: 0
  • Environment.txt
    1,020 bytes · Views: 0
  • wpscompile.log
    38.9 KB · Views: 0
The solution is to replace metgrib.exe->src->scan_input.
 
Last edited by a moderator:
Top