Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Creating executables problems when compiling WRF

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am having issues with the executable creation when I am compiling WRF. I looked at all the other suggestions, and they haven't worked for me. I attached my log file, and it appears that there is a common error:

ifort: command line error: Unrecognized keyword 'array64byte' for option '-align'
make[3]: [mradb5.o] Error 1 (ignored)

My gcc version and gfortran version are as follows:

gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-23)

GNU Fortran (GCC) 4.4.7 20120313 (Red Hat 4.4.7-23)

I am not sure how to go about fixing this error.

Any help would be greatly appreciated.

Thank you so much!


  • log.compile
    622 KB · Views: 44
Are you specifically trying to build with AVX options or a MIC PHI chip? If not, and all you want is a general Intel compiler, try the compiler option 15 for Linux (this is Intel with MPI).

Is this build on a cluster or a desktop / laptop?

Since you are using the Intel compiler, we are not too concerned with your gcc version.
I changed it to 15 and it worked... Thank you! I ran into a different problem however and am posting on that in a different section.

Thanks again!