Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error in opening the compiled module file. Check INCLUDE paths.

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello guys.

Please help me with WRFDA compilation errors. Right now I have compiled succesfully WRF with WPS by following this guide: . Actually I compiled wrf and wps with the option parallel (dm-parallel), linux, intel compilers (DM_FC = mpiifort, DM_CC = mpiicc) and I configure in the same way the configure.wrf file for compiling wrfda but I got a lot of errors like this:

da_wrfvar_main.f(18): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [DA_WRFVAR_TOP]
use da_wrfvar_top, only : da_wrfvar_init1,da_wrfvar_init2,da_wrfvar_run, &
da_wrfvar_main.f(27): error #6406: Conflicting attributes or multiple declaration of name. [DA_WRFVAR_INIT1]

I have also tried to compiled with serial option but I still have those errors. I have already expoerted the variables:

export CC=gcc
export CXX=g++
export FC=gfortran
export FCFLAGS=-m64
export F77=gfortran
export FFLAGS=-m64
export JASPERLIB=/share/libs/jasper/1.900.1/lib
export JASPERINC=/share/libs/jasper/1.900.1/include
export LDFLAGS=-L/share/libs/jasper/1.900.1/lib
export CPPFLAGS=-I/share/libs/jasper/1.900.1/include
export PATH=/share/libs/netcdf/4.3.2-intel/bin:$PATH
export NETCDF=/share/libs/netcdf/4.3.2-intel
export PATH=/opt/mpi/openmpi_intel-2.1.1/bin/:$PATH
export NETCDF=/share/libs/netcdf/4.3.2-intel
export HDF5=/share/libs/hdf5/1.8.14-intel
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/share/libs/hdf5/1.8.14-intel/lib
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/share/libs/netcdf/4.3.2-intel/lib
source /opt/mpi/openmpi_intel-2.1.1/bin/

and I run the compilation with this screen command, just in case my ssh connection get lost:

screen -d -m -L -S compilacionwrfda ./compile all_wrfvar >& compile.out

Could you please give me any ideas to solve those compilation errors, I am following the official wrf guide ?

Thank you in advance for any help.
Hi Soportemm,

I am experiencing the same problems you had in the past. Did you find a solution?