Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Error on processing of static, geographical fields

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


In the tutorial, for processing the static geographic fields it is indicated to set up the namelist.init_atmosphere as follows:

    config_geog_data_path = '/classroom/wrfhelp/mpas/geog/'
    config_landuse_data = 'MODIFIED_IGBP_MODIS_NOAH'
    config_topo_data = 'GMTED2010'
    config_vegfrac_data = 'MODIS'
    config_albedo_data = 'MODIS'
    config_maxsnowalbedo_data = 'MODIS'
    config_supersample_factor = 3

However, as I am outside of NCAR, I do not have access to this 'classroom' folder. So I trying to set up the namelist using the files provided in the tutorial as in View attachment namelist.init_atmosphere.txt.

Using this, the processing seems to run just fine, as there are no errors. However, when I run the plot_terrain.ncl script to see the terrain, it shows a map with no terrain: View attachment terrain.pdf

Is this just me indicating the model to read the wrong terrain files or is it something else?
Can you attach your log.init_atmosphere.0000.out? I'd like to see if it was able to read in each static dataset tiles. As well, can you provide a copy of your streams file?

If you've downloaded the tutorial geog directory (../mpas_tutorial/geog/) from the mpas_tutorial, then you should have access to the static datasets needed for this preproc stage. However, just to be sure, when you `ls` your geog dir, does it have the following directories?

$ ls ../mpas_tutorial/geog
albedo_modis  albedo_ncep  greenfrac  greenfrac_fpar_modis  landuse_30s  maxsnowalb  maxsnowalb_modis  modis_landuse_20class_30s  soiltemp_1deg  soiltype_top_30s  topo_30s  topo_gmted2010_30s
Thanks for the reply.

I've started over and everything worked just fine. It was probably some error in namelist or streams files that I was not able to spot.

However, I still have one issue, if you may help me. I've followed the rest of the tutorial to perform a real-data simulation and when I attempt to run MPAS using 4 MPI tasks I get the following error: ERROR: Could not open block decomposition file for 4 blocks.. I also attached the log files and namelist/streams files in case you might need them.

Thank you!



  • streams.init_atmosphere.txt
    922 bytes · Views: 25
  • streams.atmosphere.txt
    1.5 KB · Views: 20
  • namelist.init_atmosphere.txt
    1.4 KB · Views: 23
  • log.init_atmosphere.0000.out.txt
    5.4 KB · Views: 22
  • namelist.atmosphere.txt
    1.7 KB · Views: 24
  • log.atmosphere.0003.out.txt
    1.6 KB · Views: 20
  • log.atmosphere.0002.out.txt
    1.6 KB · Views: 20
  • log.atmosphere.0001.out.txt
    1.6 KB · Views: 22
  • log.atmosphere.0000.out.txt
    2 KB · Views: 24
  • log.atmosphere.0000.err.txt
    415 bytes · Views: 21
Glad things worked for your first problem.

For your next problem the model is telling you that it can not find the graph partition for four processors. In your atmosphere.namelist, you have config_block_decomp_file_prefix set to ''. This means, the model is looking for graph decomposition in the same directory that the model is being run in. Remember, the model takes this filename, and appends the number of tasks to it, which in your case is 4. Thus, the model is looking for the file named:

Thus, you need to locate this file (and perhaps the other decompositions) and update config_block_decomp_file_prefix accordingly. For example:

congfig_block_decomp_file_prefix = '/path/to/'

If you are using the grids that were provided in the mpas_tutorial.tar.gz file, then these files reside under the meshes directory: '/path/to/meshes/'

Alternatively, you can also move the graph partition you want to use into the directory you want to run the model, and leave config_block_decomp_file_prefix as it is.