Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

except EOFError when running tutorial examples

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I am going through the MPAS-A tutorial and running all examples, but when I try to run the supercell idealised conditions with:

mpiexec -n 4 ./atmosphere_model

I get:

File "/opt/intel/composer_xe_2013.0.079/mpirt/bin/intel64/mpiexec", line 187
    except EOFError, e:
SyntaxError: invalid syntax

Is this an issue exclusively with mpi or am I doing something wrong? Running init_atmosphere did ok
This looks like it may be a problem with your MPI implementation (specifically, in the 'mpiexec' command, which may be a script). If you have any other MPI "hello, world" programs, could you try running one of them in parallel with 'mpiexec'? It may even be a useful test to try running 'mpiexec --version'.
Hello mgduda, thank you for the reply.

I changed the MPI source and that error disappeared. However I'm facing new issues. I'm still not able to run"supercell" example from the MPAS-Tutorial: "1.4 Preparing idealized initial conditions". It seems that I was successful at creating the initial conditions, but when I attempt to run the atmosphere_model with:

mpiexec -n 4 ./atmosphere_model

I get the screen error described in "error.txt.". I've also uploaded de log files just in case. Do you have any ideas of what might be going on?


  • error.txt
    44 KB · Views: 27
  • log.atmosphere.0000.out.txt
    15.4 KB · Views: 22
  • log.init_atmosphere.0000.out.txt
    16.6 KB · Views: 27
From your error log it looks like you may be using the Intel 2013 compilers. I recall that we had some issues around 2012-2013 with the Intel compilers with MPAS-Atmosphere, though I couldn't say with certainty exactly what the issues were and when they were resolved (in the Intel compilers).

Do you have any other compilers available on your system that you could try, for example, a newer version of the Intel compilers or a recent release of the GNU compilers?

If no newer compilers are available, you could also try cleaning the atmosphere core and recompiling with DEBUG=true. If the problematic code can be identified, it may be possible to come up with a work-around.
Unfortunately there are no newer compilers available, so I recompiled it using the DEBUG=true as suggested. The logs attached are relative to building the init_atmosphere_model and atmosphere cores, just in case.

Thank you,



  • log_build.txt
    71.1 KB · Views: 29
  • log_build2.txt
    140.8 KB · Views: 28
Sorry -- I should have been clearer in my previous post. Can you try running the code that was compiled with DEBUG=true to see if there are any useful messages printed at runtime? The DEBUG=true option enables additional runtime checks, e.g., for out-of-bounds array accesses, for uses of unassociated pointers, and for floating-point exceptions.

Your build logs suggest that you may in fact be using the GNU compilers (possibly 8.3.0?) rather than the Intel 2013 compilers. Can you clarify which compilers you're using?
No worries, that was probably my fault for misinterpreting.

Ok, just so you can double-check if everything is ok: I did a make clean in the MPAS_model folder and then compiled it again using the DEBUG=true option. Then, I downloaded the supercell.tar.gz file, made the link to the init_atmosphere and atmosphere cores that are in the MPAS_model folder and attempted to run init_amosphere.

Now the error seems different, I imagine that might be due to the debug flag, but it is now pointing issues with the namelist file? It is my first attempt to run a simulation with the MPAS so I'm not used to the name list inputs yet, but the tutorial page suggested that this namelist file (from the supercell test case folder) would be already ready for use...




  • log.init_atmosphere.0000.txt
    6 KB · Views: 30
Your process sounds correct to me. I think you're right that the extra checks are causing the supercell initialization to fail: I ran a couple of tests here and it seems that there may be an uninitialized array (qvb) in the init_atm_case_squall_line routine that is at fault (and the failures aren't necessarily repeatable, as we would expect with uninitialized memory).

Just to see whether any other idealized cases work, would you be willing to give the Jablonowski and Williamson baroclinic wave case a try? If that works, that would at least give some confidence that the init_atmosphere_model and atmosphere_model programs are capable in principle of working correctly on your system.
I am running the Baroclinic Wave right now. If I understood it correctly, the simulation is set to last for 16 days and so far it completed 3 days of simulation. It's been running for a couple of hours so I reckon it won't finish today, but at least it suggests that the problem is no my system. Instead, should be something specifically related to the supercell example, I wonder.

I guess that if this baroclinic wave simulation succeed I'll attempt other examples. If they all succeed, I'll continue with the tutorial and attempt a real-data simulation hoping that the issue is solely with the supercell example.

Thanks for the assistance!