Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

FASTJ subr OPMIE error. Max NL exceeded

maosier

New member
Hi,

I'm running WRF-Chemv3.9.1 with Fast-J (phot_opt=2). I got a problem during the simulation:
FASTJ Max NL exceeded jaddto(nc)+nc NL 501 500
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 76
FASTJ subr OPMIE error. Max NL exceeded
It seems something was wrong during the photolysis process. Could you help me solve the problem?

Thanks,
Maosier
 

Attachments

  • rsl.error.0020.txt
    260 KB · Views: 3
  • rsl.out.0020.txt
    287.1 KB · Views: 2
Hi Maosier,

Some sort of instability was reached (usually caused by very high concentrations of a species). Please attach your namelist.input.

Jordan
 
Hi Jordan,

Thanks for your reply. The namelist.input has been attached.

Maosier
 

Attachments

  • namelist.input
    9.3 KB · Views: 8
Hi Maosier,

One thing I noticed is that your number of vertical levels is quite small. I see you have specified them - did this configuration work for a previous simulation? My first suggestion would be to increase e_vert (maybe try 40?). You can leave the eta_levels option empty. You will also need to re-run real.exe before using wrf.exe.

Also, take a look at any output files that have been generated, are there any very high concentrations of PM2.5?, If so, you can try turning off aer_ra_feedback. Or turning off dust and anthropogenic emissions or turning off aerosol and gas chemistry altogether.

There is also a parameter in chem/module_phot_fastj.F (NL=500) that you could adjust (and recompile the model), but that should be a last resort.

Jordan
 
Hi Jordan,

This configuration worked well for the previous simulation. So I tried to increase the parameter NL from 500 to 700 and recompiled. The crash still occurred. Are there any other possible solutions?

Maosier
 
Top