Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

gasodesolver_lsodes failure no

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

lobster

New member
hi all
I get this error when runing wrf.exe

d01 2005-09-28_01:59:30 7.1700000000E+03
d01 2005-09-28_01:59:30
d01 2005-09-28_01:59:30 *** gasodesolver_lsodes failure no. 1001
d01 2005-09-28_01:59:30 iregime, iok, i, j, k / t
d01 2005-09-28_01:59:30 1 -1 354 157
d01 2005-09-28_01:59:30 7.1700000000E+03
d01 2005-09-28_01:59:30 *** exceeded lsodes failure limit = 1000
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 76
*** exceeded lsodes failure limit = 1000

My version is 3.9.1. Start time is 2005-09-28_00:00:00 and I use cbmz-mosoic chemistry option. Here is my namelist:
&time_control
run_days = 0,
run_hours = 84,
run_minutes = 0,
run_seconds = 0,
start_year = 2005, 2005, 2999,
start_month = 09, 09, 06,
start_day = 28, 28, 11,
start_hour = 00, 00, 12,
start_minute = 00, 00, 00,
start_second = 00, 00, 00,
end_year = 2005, 2005, 2999,
end_month = 10, 10, 06,
end_day = 01, 01, 12,
end_hour = 12, 12, 12,
end_minute = 00, 00, 00,
end_second = 00, 00, 00,
interval_seconds = 21600
input_from_file = .true.,.true.,.true.,
history_interval = 60, 60, 60,
frames_per_outfile = 24, 24, 24,
restart = .false.,
restart_interval = 5000,
auxinput5_interval_m = 86400, 86400, 86400
io_form_history = 2
io_form_restart = 2
io_form_input = 2
io_form_boundary = 2
io_form_auxinput4 = 0
io_form_auxinput5 = 2
io_form_auxinput6 = 0
debug_level = 00

auxinput5_inname = 'wrfchemi_d<omain>_<date>',
auxinput6_inname = 'wrfbiochemi_d<domain>',
/

&domains
time_step = 30,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 2,
e_we = 360, 379, 271,
e_sn = 332, 337, 247,
e_vert = 60, 60, 60,
eta_levels =1.000,0.998,0.996,0.994,0.992,
0.990,0.985,0.980,0.975,0.970,
0.965,0.960,0.955,0.950,0.945,
0.940,0.935,0.930,0.925,0.920,
0.915,0.910,0.905,0.900,0.895,
0.890,0.885,0.880,0.875,0.870,
0.865,0.860,0.855,0.850,0.840,
0.830,0.820,0.800,0.780,0.750,
0.700,0.650,0.600,0.550,0.500,
0.450,0.400,0.350,0.300,0.250,
0.200,0.150,0.100,0.088,0.070,
0.055,0.040,0.026,0.013,0.000,
dx = 18000, 6000, 6666.66,
dy = 18000, 6000, 6666.66,
p_top_requested = 5000,
num_metgrid_levels = 27,
num_metgrid_soil_levels = 4,
grid_id = 1, 2, 3,
parent_id = 0, 1, 2,
i_parent_start = 1, 120, 73,
j_parent_start = 1, 80, 54,
parent_grid_ratio = 1, 3, 3,
parent_time_step_ratio = 1, 3, 3,
feedback = 1,
smooth_option = 0
/

&physics
mp_physics = 10, 10, 10,
progn = 1, 1, 1,
ra_lw_physics = 4, 4, 4,
ra_sw_physics = 4, 4, 4,
radt = 18, 6, 5,
sf_sfclay_physics = 1, 1, 1,
sf_surface_physics = 2, 2, 2,
bl_pbl_physics = 1, 1, 1,
bldt = 0, 0, 0,
cu_physics = 3, 0, 0,
cudt = 0, 0, 0,
cu_diag = 1, 0, 1,
isfflx = 1,
cugd_avedx = 1,
ifsnow = 1,
icloud = 1,
surface_input_source = 3,
num_soil_layers = 4,
sf_urban_physics = 0, 0, 0,
mp_zero_out = 2,
mp_zero_out_thresh = 1.e-12
maxiens = 1,
maxens = 3,
maxens2 = 3,
maxens3 = 16,
ensdim = 144,
cu_rad_feedback = .true.,.false.,.false.,
num_land_cat = 24,
/

&fdda
/

&dynamics
w_damping = 0,
diff_opt = 1,
km_opt = 4,
diff_6th_opt = 0, 0, 0,
diff_6th_factor = 0.12, 0.12, 0.12,
base_temp = 290.
damp_opt = 0,
zdamp = 5000., 5000., 5000.,
dampcoef = 0.2, 0.2, 0.2
khdif = 0, 0, 0,
kvdif = 0, 0, 0,
non_hydrostatic = .true., .true., .true.,
moist_adv_opt = 2, 2, 2,
scalar_adv_opt = 2, 2, 2,
chem_adv_opt = 2, 2, 2,
tke_adv_opt = 2, 2, 2,
/

&bdy_control
spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true., .false.,.false.,
nested = .false., .true., .true.,
/

&grib2
/

&chem
kemit = 1,
chem_opt = 10, 10, 10,
bioemdt = 30, 30, 30,
photdt = 30, 30, 30,
chemdt = 3, 1, 0,
io_style_emissions = 2,
emiss_opt = 4, 4, 4,
emiss_inpt_opt = 101, 101, 101,
emiss_opt_vol = 0, 0, 0,
emiss_ash_hgt = 20000.,
chem_in_opt = 1, 1, 1,
phot_opt = 1, 1, 1,
gas_drydep_opt = 1, 1, 1,
aer_drydep_opt = 1, 1, 1,
bio_emiss_opt = 0, 0, 3,
ne_area = 150,
dust_opt = 0,
dmsemis_opt = 0,
seas_opt = 2,
depo_fact = 0.25, 0.25, 0.25,
gas_bc_opt = 1, 1, 1,
gas_ic_opt = 1, 1, 1,
aer_bc_opt = 1, 1, 1,
aer_ic_opt = 1, 1, 1,
gaschem_onoff = 1, 1, 1,
aerchem_onoff = 1, 1, 1,
wetscav_onoff = 1, 1, 1,
cldchem_onoff = 1, 1, 1,
vertmix_onoff = 1, 1, 1,
chem_conv_tr = 1, 0, 1,
conv_tr_wetscav = 1, 1, 1,
conv_tr_aqchem = 1, 1, 1,
biomass_burn_opt = 1, 1, 1,
plumerisefire_frq = 30, 30, 10,
have_bcs_chem = .true., .true., .true.,
aer_ra_feedback = 1, 1, 1,
aer_op_opt = 1, 1, 1,
opt_pars_out = 1,
diagnostic_chem = 1, 1, 1,
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/
 
Hi,

Some suggestions for debugging this.

1) Does this occur when you run only 1 domain, not 2? If not, then also try switching off feedback from the inner domain (feedback = 0), to see if that is causing the problem.

2) Could it be caused by the emissions you are putting in? Could you try switching off your biomass burning emissions, and then your anthropogenic emissions, to see if you don't get this error without one of these emissions inputs? Also, you probably add some biogenic emissions too - try using bio_emiss_opt = 1, or use the megan preprocessor to create input files for use with bio_emiss_opt = 3.

3) Look for evidence of unusual inputs or chemical composition at the location of the problem. The error message gives the grid location of the problem, to help you do this (though it isn't clear which domain this is on):
Code:
d01 2005-09-28_01:59:30 iregime, iok, i, j, k / t
d01 2005-09-28_01:59:30 1 -1 354 157
i=354, j=157

You could look at the emissions around this location, and/or increase the frequency of your outputs (e.g. history_interval = 5, 5), so that you will get a snapshot of the chemical fields just before this occurs, so that you can check if these look sensible or not.
 
Hello, I am having the same problem too, and I tried doing the steps you said. I ran with only one domain, d01, which worked fine. I now want to also use a second domain, d02, but I am having a lot of problems. I have the gasodesolver_lsodes failure for each i and j value, until eventually it exceeds the lsodes failure limit, and there is a fatal error. I am not using any emissions inputs, only the boundary and initial conditions from mozbc.
The fact that there is an error in what seems to be every point in d02 (at least, this is what I understand from the gasodesolver_lsoldes i and j values), it leads me to believe that there was a problem in the mozbc process for d02. Does anyone have any experience with this?
Any help would be highly appreciated!
 

Attachments

  • namelist.input
    4.9 KB · Views: 85
  • rsl.error.0000.txt
    3.6 MB · Views: 73
  • rsl.out.0000.txt
    3.6 MB · Views: 68
Hello, I am also facing the same error. Kindly help if anyone has the solution. I am running for one domain only.
 

Attachments

  • namelist.input
    6.6 KB · Views: 41
  • rsl.error.0091.txt
    2.1 MB · Views: 34
I am having the same problem. I am running using a single domain with CBMZ MOSAIC scheme. Total run days is 15. Can anyone help?
 
Top